arduino uno + power supply (PC) + tlc5940 + servo 9g

I'm using a power supply computer ("5v red wire" and "ground black wire") but my TLC5940 is failing to run all sixteen "servo 9g."
A maximum I can run 6 simultaneous servo.
or
A maximum servo 14 one at a time.

How to solve this situation?

(IMPORTANT: Im using "power supply computer"
images of components:



Hi, what do you mean by "failing", they won't work at all, they jitter, they are inaccurate in their movements?

Have you measured the 5V from the computer supply when the "failure" occurs? Measure the supply at the power supply and then at the driver board where the 5V goes in when the failure is occuring.

You may have wiring that is too thin for the currents that the servos draw when you want a number of them to operate together.

I see that the arduino gets its supply from the driver board, is there any bypassing of the supply to the arduino to stop noise from the servos getting to the arduino?

A photograph of the whole setup will probably help us to help you.

Tom. :slight_smile:

look this...

Wires are the same size as the wires of servos.

Your video is not very helpful. Not sure what you thought the music would add. Hearing the noises made by the servos would have been far more helpful.

Do you know or have you looked for the specs of the servos? My searching says 100-200ma no load, 10ma idle and up to 600ma stalled. 4.8V is used for the torque rating so 5V should be fine.

Do you know the specs of your power supply?

Running 9 servos @ 200ma each == ~1.8A unloaded.

16 servos @ 200ma will be 3.2A unloaded.

Also, providing the code you are running that is not working would help in seeing what PWM values you are setting for the servos.

At a guess, I am thinking your PSU cannot supply sufficient current, given the circuit works with 9 but not more.

code and connection are the same:
http://bildr.org/2012/03/servos-tlc5940-arduino/


1 - I found that the voltage is dropping to 3.5V, can this be?
2 - tested with 3 computer sources and in all of them the voltage drops.
3 - tested with two sources together, and even then the voltage drops.
4 - the question is: How can the voltage does not drop. (anyone know?)

Hi, where are you measuring the 5V supply, at the plug at the power supply or at the arduino board?
If it was at the arduino board, then remeasure it at the plug at the power supply.
If the supply stays around 5V there but it is dropping when measured at the arduino end of your wiring then your wiring is to thin.
You did answer my question about wire size saying it is the same a each servo, probably not heavy enough.
Tom.. 8)
PS It also looks like the 5V from the power supply is running through the protoboard, not good for your application.
The power for the servos should come directly from the supply plug.

-Im measure from the power supply, and voltage drops from 5v to 3.5v when powered.
-Cables are not the problem because I tried with larger cables.
-AND.... Why is it a problem to use a protoboard for connections ?????

Base load?

HI, fine on where you are measuring the supply volts, can you now measure the supply current under both load conditions?
By all calculations a computer supply should be okay, but if you can measure the current then it will help.
Tom.. :slight_smile:

hey guys,

thank you all, the problem was solved.

I put the fonts(direct on tlc5940) without the protoboard and it worked.