Arduino Uno R3 With Mac OS X 10.9 Mavericks Not Detected/ No Serial USB

Hello, I am posting in the hopes of getting some help with arduino.

I have used arduino for about 1.5 years already on 10.8, and had no problems.

However today I tried to use it on Mavericks (10.9.1) and no matter what I do I cannot get the arduino uno to show on the computer. The IDE ONLY shows the following:

/dev/tty.Bluetooth-Incoming-Port /dev/cu.Bluetooth-Incoming-Port /dev/tty.Bluetooth-Modem /dev/cu.Bluetooth-Modem

Furthermore, I deleted and tried to reinstall arduino following the sites instructions, and nothing prompts me about it being a network device either, nor is it listed in the network panel.

When I plug in with USB, it does power on (green LED is on, and the light near pin 13 blinks when first plugged in then shuts off shortly after).

I have been trying to fix this for 3 hours now with no luck and have tried everything I found online, including disabling the apple driver and installing the latest FTDI drivers.

All help appreciated as this is extremely important.

Thank you.

I am trying to confirm a bug that may be related to yours. I'm using Mavericks and FTDI drivers are installed.

My Arduino Nano is getting power from USB and is powered up when booting up the computer. It will not show up in the list of serial devices unless I remove and reconnect the device from the USB port. I think the problem has something to do with the FTDI driver being loaded while the Arduino is still in its boot up sequence, but not sure.

Could you confirm that your device shows up after removing and reconnecting it to USB/power.

I'm hoping there's a way to re-initialize the FTDI driver and recognize the Arduino without having to physically detach and reattach it.

I got the same problem, how did it work out with yours? what did you do to let it work?

david

Does the Arduino show up in "System Information" under USB?

Same issue for me. The board does not show up under system information either.

Hi, I have the same problem.

I checked the Disk Utility and (In Spanish it calls Informacion del Sistema, I don’t know the name in english)I think is System Profiler. Mac doesn’t recognized the USB Wire.
In the DU, you only can see the FTDI, and thats all.

I hope somebody had a answer.

Oscar Espinosa

Pd: I bought the Arduino UNO, first of all y plug in the USB port of the Mac, the Arduino works by 2 days.
The third day, in the evening it just stop working.

Just to say that I have no problem using the Arduino with Mavericks, and that includes using the Due, Uno, Galileo, Leonardo and Tiny. Sorry no insight on how to cure it I just know I have no problem.

Hi, I have the same problem and i have mac os 10.9.3 I tested on mac book air and mac book pro without success. The Arduino receive power through the usb port but i cannot detect and connect to it. Did you solved the issue ? thx

Hi,

I have the same problem :confused:
i have mac os 10.9.4
it’s very strange because sometimes in my /dev/ ( when i restart, running naked in the street, when i claps three times in my hands )
Arduino is detected… :

/dev/cu.usbserial-xxxxxxxx
/dev/tty.usbserial-xxxxxxxx

but it’s very random :fearful:

so if any person found a solution please, no … PLEASE! Say me u_u ( i will go crazy ! ) :sweat_smile:

sorry for my english i’m french :slight_smile:

I'm having the same problem with the Freeduino v1.22. I only get bluetooth devices under Tools > Port. I tried removing the Mavericks drivers as per these instructions:

cd /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns sudo mv AppleUSBFTDI.kext AppleUSBFTDI.disabled sudo touch /System/Library/Extensions

reboot

After rebooting I tried installing the FTDI drivers as over 9000 people on the Internet said to do: http://www.ftdichip.com/Drivers/VCP.htm.

Despite what some Google result said that this would work, this did not work for me.

Official Arduinos work, unfortunately I teach a workshop with Freeduinos and my students are 95% OS X. I hate Oracle. I hate Apple but I can't tell everyone in my class to run Linux.

This is the error I get from the IDE when the board is plugged in:

Exception in thread "AWT-EventQueue-0" java.lang.IllegalArgumentException: Bounds out of range: -1,76 [128] at processing.app.syntax.JEditTextArea.select(JEditTextArea.java:1178) at processing.app.syntax.JEditTextArea$MouseHandler.doDoubleClick(JEditTextArea.java:2353) at processing.app.syntax.JEditTextArea$MouseHandler.mousePressed(JEditTextArea.java:2305) at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:280) at java.awt.Component.processMouseEvent(Component.java:6524) at javax.swing.JComponent.processMouseEvent(JComponent.java:3321) at java.awt.Component.processEvent(Component.java:6292) at java.awt.Container.processEvent(Container.java:2234) at java.awt.Component.dispatchEventImpl(Component.java:4883) at java.awt.Container.dispatchEventImpl(Container.java:2292) at java.awt.Component.dispatchEvent(Component.java:4705) at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4898) at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4530) at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4462) at java.awt.Container.dispatchEventImpl(Container.java:2278) at java.awt.Window.dispatchEventImpl(Window.java:2739) at java.awt.Component.dispatchEvent(Component.java:4705) at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:746) at java.awt.EventQueue.access$400(EventQueue.java:97) at java.awt.EventQueue$3.run(EventQueue.java:697) at java.awt.EventQueue$3.run(EventQueue.java:691) at java.security.AccessController.doPrivileged(Native Method) at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75) at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:86) at java.awt.EventQueue$4.run(EventQueue.java:719) at java.awt.EventQueue$4.run(EventQueue.java:717) at java.security.AccessController.doPrivileged(Native Method) at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75) at java.awt.EventQueue.dispatchEvent(EventQueue.java:716) at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201) at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116) at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93) at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Hi. I am having the same issue too. To be more specific, my Mac can see an Arduino UNO however the nano only let's me see the following:

/dev/tty.Bluetooth-Incoming-Port /dev/cu.Bluetooth-Incoming-Port /dev/tty.Bluetooth-Modem /dev/cu.Bluetooth-Modem

If I plug in the Uno, I see the same but augmented with the USB choices (correct).

I have tried all the common problems solutions (new cable, plugging in again etc) but nothing works.

Did anyone ever see a solution for this?

OK. I just got my Uno R3 (authentic Arduino out of box) working. I, like you, spent truckloads of time on this.

I'm running 10.10.2 Yosemite. Java 1.8.0_31-b13 (aka Java 8). Arduino IDE 1.6.

First, ignore all that FTDI driver stuff. The Uno R3 (Arduino branded) does not use this chipset. There are NO drivers required to get this board working. It loads drivers from firmware when you connect it.

Next, if you check your version of Java in Terminal, it won't respond to > Java -version. It will just keep prompting you to install Java unless you have an old version of Java (like Java SE 6) installed. If you want to know if it's installed correctly, a tip-off is that you should see a Java icon in your System Preferences pane.

What mystified me is I bought two Uno R3 boards, and two USB 2.0 A to B cables. I have two Macbook Pros and one Macbook Air in the house and an HP laptop. Nothing worked. Not even recognized by the OSes, let alone the Arduino IDE.

I wanted this to work on the Mac because my son and I are both experimenting with the boards. Finally (as I mentioned above), I broke down and used my HP laptop from work to try and get it working. Nothing.

So I went and bought a different USB cable from a different place.

It worked. It shows up as USB Modem - Not Configured in the Network pane under System Preferences. It shows up as /dev/cu.usbmodemfd131 (Arduino Uno) under the Arduino IDE Tools>>Port menu.

I suspect some USB cables are sh*t (I'm shocked!). I'm not sure if the hardware is just sensitive or whether someone managed to botch a simple USB cable run, but this was my experience. I hope this helps you.

d.

I'm also having this same issue.

I purchased my Arduino UNO Rev3 three days ago.

I needed three attempts to get my mac recognising it as a modem port. Later everithing worked fine for two days until I wrote a sketch for my DHT11 and tried to upload it. My Arduino stopped connecting to my mac. The last sketch I uploaded was working fine. This morning, after hours and hours trying everything I got it working by shorting between reset&GND + Tx&Rx.

Now, tried to upload a DHT11 sketch again (different) and my Arduino is like a brick again.

I've tried 5 different cables with no success. DFU mode doesn't works.

What can I do? Thank you

Twelve messages. Fifteen months with the same problem. NO useful replies.

By all means, check the forums....

Mac users are orphans in Arduino land....

Hello, I find myself newly in this same situation.

Config:OSX Yosemite 10.10.3, Java 8 Update 45, Arduino IDE 1.6.3.

I updated to all of these as of last week. I can no longer upload to my Uno R.3 (official) through the IDE. Getting the error message:

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00

Yes, power-on LED is lit and LED next to pin 13 blinks rapidly on power-up or reset.

I can see the board in the USB tree of the System profiler. I get a port in the IDE, but I'm pretty sure it is not right. The only non-Bluetooth option is /dev/cu.usbmodem121 (Arduino Uno). Pretty sure it should be /dev/tty.*** but that is not available in the port menu.

Interesting, I can still upload to my Gen. 1 Galileo board.

Any new insights in to fixing this problem? Thank you, all.

Hey all,

At least it sounds like most of you are getting the IDE to even start! Intermittently... no lets change that to spasmodically, because I yet to figure out or identify a failure mechanism that cause the IDE to hang on startup. Good cables, Shows up in USB tree Serial connection shows OSX 10.10.3 IDE 1.6.3 FTDI 1.04 Mega 2560/Uno R3

Only thing that works (sometimes) is a complete restart of the iMac. Can happen anytime. Was programming for a few hours, got a programmer not responding error (on UNO). Now I can't get Arduino to even start it just hangs

Any ideas????

Thoroughly frustrated!!!

Joe B

Hi all, I just got my Uno R3 and to my excitement and then disappointment my Mac pro on yosemite 10.10 has not been able to connect with USB. I flashed using the DFU as mentioned all over the place and using Arduino factory USB firmware for atmega16u2 and nothing.

553 dfu-programmer atmega16u2 erase 554 dfu-programmer atmega16u2 flash Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex 555 dfu-programmer atmega16u2 flash Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex --suppress-bootloader-mem 556 dfu-programmer atmega16u2 reset 557 dfu-programmer atmega16u2 erase 558 dfu-programmer atmega16u2 erase 559 dfu-programmer atmega16u2 flash Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex 560 dfu-programmer atmega16u2 flash Arduino-COMBINED-dfu-usbserial-atmega16u2-Uno-Rev3.hex --suppress-bootloader-mem 561 dfu-programmer atmega16u2 reset

The USB is found on the system report:

Communication Device:

Product ID: 0x0043 Vendor ID: 0x2341 Version: 0.01 Serial Number: 9533633363535160B192 Speed: Up to 12 Mb/sec Manufacturer: Arduino (www.arduino.cc) Location ID: 0x14100000 / 12 Current Available (mA): 500 Current Required (mA): 100

So there is something connected to the USB port but the firmware fails to play nicely with USB. IDE works but the tty.usbmodem never showed up and I could never try the blink sketch.

I will try to buy a new cable as I tried with another one and it did not work. I also will try on the other iMac I have see if I'm lucky.

Anything else I should try before contacting Arduino to get a new board?

Best, Johnny

Me again.

So I figured out a work around. I run Windows 8.1 on Virtual Box (VB) with the same cable and board and I can now upload the blink sketch.

So there is definitely something to do with Mac OS X driver to support the atmega16u2. Windows 8.1 installed the drivers and I started Arduino IDE and the COM4 for me was my Uno.

I wish it was more simple as I prefer to work on OS X environment but at least 1) this proves my Uno works and 2) this keeps me learning the great platform.

I hope this helps as a work around for someone else.

I'm still interested though on getting this resolved so I don't have to spin off VB everytime I want to work on the board. Let me know if someone finds a solution.

Best, Johnny