Arduino Uno Usb Serial ISSUE

Hi, i’ve bought a coupple of day ago an Arduino Uno and a Tft Lcd screen just to play and create something!

So here is my problem, after two days of perfect working something has changed,

I can’t write and upload nothing on my arduino, and THE MOST IMPORTANT THING is that i can’t choose the USBMODEM as the port for the programming…

Anyone can help me? thank you!

Have you tried to upload without the TFT Screen?

Yes, this issue just came out when i've upload another program, after the complete uploading of the program the arduino just not respond, the tft lcd does not get black as always and no reply from the arduino...

i've tried to connect it without the tft, and in the IDE the tty.usb ecc does not appear, and i've checked on the system profiler on my mac, no arduino or Atmega appear!

I think your Atmega8u2/16u2 got zapped.

With your Uno plugged in, short these two pin for a second:

If something happens, go ahead and cancel the action and unplug and plug the Uno back into the USB.

What does that reset do? The reason I ask is a ran across a similar issue.

I programmed a little test program to test an odd baud rate output from the UNO and loaded it. Everything went fine and the serial program worked, and I finished my test. My goal was just to see if I could program non-standard baud rates and get the proper output, turns out I can.

The problem comes when I try to load anything else onto the board, the serial port in the Tools menu is grayed out and serial commands fail to the USB interface.

I did a search on the problem and tried a number of solutions, nothing seemed to work.

I finally took a virgin Atmel chip with the Arduino bootloader and replaced the chip on the UNO, then I got the serial port set and the menu working. I was then able to return the "failed" chip and get a non-serial data program loaded.

How do I program a serial application using the serial port and not risk locking up the board? I really don't want to run through this rain-dance every time I want to use the serial port!

It resets the Atmega8/16u2 on the Uno and switches it to device firmware update. For windows and linux, Atmel has a program called FLIP that will allow you to reprogram the 8/16u2 chip via USB.

http://www.atmel.com/tools/FLIP.aspx

Unfortunately, the Atmega328 does not have native USB, so FLIP can not be used for programming. If you were to get an USBtiny or equivalent programmer, you could have a recovery route by just reflashing the chips that get tweeked. All firmwares are located in the \arduino-1.0.1\hardware\arduino\firmwares directory.

Done the reset thing, and nothing happened, no usb recognition nothing at all, i'm going to buy another AtMega with the arduino mapping, only 4 euro, that's fine!

Unfortunately, with zero communications, you might have a bad Atmega8u2 or 16u2 which is that small square package below that header. You might get lucky like John did, who knows, but you might need some programming equipment.

Good luck!

dodoliva: Done the reset thing, and nothing happened, no usb recognition nothing at all, i'm going to buy another AtMega with the arduino mapping, only 4 euro, that's fine!

Well, I think I should probably get one of these. It appears that the USBtiny is a reasonable price, so I'm going to grab one of those so this doesn't bite me in the butt next time. :)

Also, with a spare Arduino, you can almost do the same with Arduino as ISP. Nick Gammon has an awesome sketch that uses the same setup as Arduino as ISP:

http://www.gammon.com.au/forum/?id=11635

Lots of options...