Arduino uno wifi rev 2 and LiquidCrystal_I2C [solved]

Hey, i’m new to arduino and ran into a problem i’m unable to fix. I just bought a Arduino Uno wifi rev 2 for a wifi project i’m making. For this project i also bought a I2C LCD display. But i can’t get the LCD display to work(it lights up but doesn’t show any text). I’m using the Wire.h and LiquidCrystal_I2C.h libary from within the IDE. The only warning i get is that the libary could be incompatible with the megaavr. I’ve tried diffrent version of the libary but same result. Currently using version 1.1.2. I’ve also tried the wire scanner and it showed up with the 0x60 adress

I’ve connected the wires as followed:
Display Arduino
GND GND
VCC 5V
SDA A4
SCL A5

This is the code i use:

#include <Wire.h> 
#include <LiquidCrystal_I2C.h>

LiquidCrystal_I2C lcd(0x60,20,4);  // set the LCD address to 0x27 for a 16 chars and 2 line display

void setup()
{
  lcd.init();                      // initialize the lcd 
  // Print a message to the LCD.
  lcd.backlight();
  lcd.setCursor(3,0);
  lcd.print("Hello, world!");
  lcd.setCursor(2,1);
  lcd.print("Ywrobot Arduino!");
   lcd.setCursor(0,2);
  lcd.print("Arduino LCM IIC 2004");
   lcd.setCursor(2,3);
  lcd.print("Power By Ec-yuan!");
}


void loop()
{
}

Anyone that knows the solution or has the same problem?
(sorry for the repost but i didn’t notice the display topic at first. I’ve now deleted my previous post)

Please do not crosspost; rather ask a moderator to move it by clicking the 'report to moderator' link under your opening post.

http://forum.arduino.cc/index.php?topic=585515

Sorry for that. Didn't know that was an option. New to the forum too. I've reported my other post

May be the address you are using is not the right one. Try with 0x27 or 0x3F.

I've tried both but it didn't solve the problem

With I2C LCDs one must know the I2C expander to LCD pin mapping as well as the I2C address. I recommend the hd44780 LCD library. That library will auto detect the address and the I2Cexpander to LCD pin mapping. The hd44780 library is available for install in the library manager. In library manager in the Topic dropdown select Displays and in the Filter box enter hd44780. Select and install the hd44780 by Bill Perry library. Use the hd44780_I2Cexp class. There is example code that comes with the library as well as a diagnostic sketch that will help troubleshoot if you still have trouble.

Thanks for the reply. I've tried the library you suggested but still have the same problem. The example uploaded perfectly but the LCD didn't show any text. The internal LED of the arduino started to blink 4 times repeatedly. I've tried running the diagnostic example but get an error that says: 'Sketch requires INPUT_PULLUP which is not supported by this IDE/core version'.

The example uploaded perfectly but the LCD didn't show any text.

Which example did you try? Was it of the hd44780_I2Cexp class?

'Sketch requires INPUT_PULLUP which is not supported by this IDE/core version'.

What version of the IDE are you using? INPUT_PULLUP is supported in IDE versions 1.01 and above.
What core (board selected in the Tools menu) are you using?

I've also tried the wire scanner and it showed up with the 0x60 adress

I know of no LCD with an I2C backpack that uses that address. Can you post a photo of the LCD? Front and back sides, please.

Yes i used the ‘hd44780 > ioClass > hd44750_I2Cexp > helloWorld’ example. I’m using version 1.8.8 of the IDE and the board i use is the arduino uno wifi rev2. I’ve also selected the ATMEGA382. I’ve attached the photos of the LCD as well as the output of the Wire scanner

I did a bit of poking around and find that the processor on the arduino uno wifi rev2 is not Mega328 (it's a ATMEGA4809) so can have issues with programs that access certain registers.

There is a forum for the Uno wifi rev 2 boards. Maybe have a moderator move this thread to the Arduino Wifi Rev2 forum where there is a better chance for an answer to your issue from members who use that board.

Ok I will try that thanks for the help anyways.

Thread moved as requested.

I don’t think that sda/scl are on a4/a5 on the wifi2. Try the r3-style pins.

Hey, wath do you mean by the R3-style pins? Can't seem to find anything that resembles that

On the same header that has pins 8..13, there are a few extra pins. The last two should be labeled SDA and SCL; @westfw suggests to try those.

[solution]
Hey @sterretje and @westfw changing the SDA and SCL cables to the SDA and SCL pins instead of the A4 and A5 pins of the arduino and changing the adress to 0x27 solved my problem(so dumb from me). You guys really are lifesavers. Thanks a lot

It's nice, because using I2C no longer takes away two analog pins.
It's not nice, because people and many "older" shields are expecting I2C on A4/A5 (actually, the MEGA boards have the same problem.)
For WiFi2, the ICSP SPI and Serial pins have similar issues:
SPI vis the ICSP connector is not 13/12/11. (also, it's shared with the WiFi and IMU.)
Serial on pins 0/1 is not the same as Serial via USB.
And Pin 13 is no longer the built-in LED, either.

The chip has 48pins instead of only 28, and the design takes advantage.
(Also true of Leonard and the SAMD21 based boards, but they're at least named more distinctly!)

I guess the I2C address 0x60 which the scanner found was either for the ECC608 crypto chip or for the NINA-W132 WiFi BLE module. The full data sheet for the ECC608 is available only under a non disclosure agreement, but from the summary it appears that its I2C address can be programmed and the default address is not stated. From the NINA-W132 (R05) datasheet, if I read it correctly, the pins which are connected to the I2C bus are marked as reserved for future use!

Overpriced betaware, I bought this board because I'd hoped it was better than just piggybacking an ESP8266 onto a Uno. Same nightmare, higher price.

I can run SPI and I2C devices on a standard Uno no problem, this so-called Uno might as well be a brick running the same code.

Live and learn.

this so-called Uno might as well be a brick

Perhaps you should describe your problems in more detail, so that the community can help find a solution, instead of just whining?