Arduino WiFi Shield

I’ve bought this Shield and tried to use it (I’m not a specialist in this). I used the example on this website: https://www.arduino.cc/en/Tutorial/WiFiSendReceiveUDPString
At the beginning all seamed to work well, only that this mention appeared on the serial monitor: “Please upgrade the firmware”. I found the necessary information on the web (Flip, USB upgrade, command line strings and so on) to do this. It seemed to work (7 times PASS, bootloader version 1.0.2) but after the last one, “Blank checking … PASS” there appeared the following in yellow: “0x00000 0x7ffff” and then in red: “FAIL Invalid or missing argument.”
I connected the shield back to the Arduino and nothing worked any more with the example above. The message on the serial monitor: “WiFi shield not present”
I’m angry: how can I go back or what is the right procedure to upgrade the firmware?

I could solve the problem by changing the path designation in the command line (see the picture CMD.jpg), where the spaces in "C:\Porgram Files (x86) ..." caused the failing. I used a relative path designation.