Ardunio UNO R3 not working with MAC OS X 10.5.8: "stk500_recv(): programmer ..."

Hello Group,

I bought an UNO R3 to learn with. I have not been able to make it work with my iMac running 10.5.8. The Arduino is recognized and listed in the USB device tree as "Arduino Uno". When I unplug the cable and refresh the USB tree, it is not listed. When pluged back in, it re-appears normally. The Arduino board seems to work fine (power led is green and yellow L Led is blinking when connected to the power supply via USB)

The board is selected as "Arduino UNO" in the Arduino window (Is this what people refer to as the IDE?)

The serial port is listed as "/dev/tty.usbmodem1d11"

Every time I try to upload a sketch I get the message:

avrdude: stk500_recv(): programmer is not responding

I have tried the various combinations of reset buttons, unplugging, etc that I read about while searching within the forum. Can anybody tell me if Arduino will work with OSX 10.5.8 and how?

Thanks in advance for any help you can provide.

Hi! I had what seems to be a similar (identical?) problem.

Running a Mac with OS X 10.6.8 and a genuine Arduino Mega 128. None of my sketches would upload (although OK on another Windows-based system); always ending up with - “avrdude: stk500_recv(): programmer is not responding”.
I found (from an old post) that I could work around by holding down (and keeping it down) the reset button until the programme size was shown in bytes of memory used, and then releasing the reset button.

This morning I have cured it totally (for now!) by: saving all my sketches; finding and trashing anything with a reference to “arduino” in the file name; re-downloading the software (and the few libraries I need).

This only took about 20 minutes going steadily, and now it works just “tinkaboo”!!
I hope this proves to solve your problem too!!

Paul G

Try the loop back tests found sticky at the top of the forum.

Is your LED on pin 13 flashing?