another "avrdude: stk500_recv(): programmer is not responding" topic

Hi everybody, I'm using an Arduino uno on a Macbook Pro 5,1 with OSX 10.5.8. I'm new to Arduino, I'm using the "blink" sketch from examples to follow some tutorials but I'm always getting the same message

avrdude: stk500_recv(): programmer is not responding

This must be something with my software because I've tried different perfectly working Arduino Uno boards and I always get the same result. It works perfectly on the same Macbook Pro on Windows Xp under Bootcamp.

I've read the troubleshooting guide and previous similar topics but I cannot find a solution. I'm pretty desperate because I want to use my board under OSX but It's impossible :( Any help is WELL appreciated This is the verbose output during upload:

Binary sketch size: 1026 bytes (of a 32256 byte maximum) /Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/tty.usbmodem621 -b115200 -D -Uflash:w:/var/folders/v7/v7drI6o3HgWa5fNC161iq++++TI/-Tmp-/build875765460005338201.tmp/Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep 2 2011 at 18:52:52 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/ Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf" User configuration file is "/Users/erarosso/.avrduderc" User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/tty.usbmodem621 Using Programmer : arduino Overriding Baud Rate : 115200 avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: ser_recv(): programmer is not responding avrdude: stk500_recv(): programmer is not responding

OK. Problem fixed after disinstalling internet key’s drivers. Hope it helps.

What are internet key's drivers? I am having the same issue - doesn't work under OS X but does with windows XP.

I mean the software you install when using a Usb Internet Key. If you are using one, try to uninstall completely the software and drivers of the internet key.