ARPS TNC with HC-06 Bluetooth Connection works one way.


I entered digital side of the electronics with this project that I am currently ripping my hair off. It is a APRS TNC as intructions are given by Mobilinkd(Hacking | Mobilinkd | Highly mobile packet radio). I learned almost everything about arduino's those required to make this work.

I made the TNC as instructions suggested and it works like charm when it is connected to PC. Sending and recieving packets correctly.

Then I tried to connect a HC-06 Bluetooth module to hardware serial of arduino nano to make the connection wirelessly so an android phone can be used.

Software comes with an .hex file and I couldn't find the source code. Even If I could find I am not sure how well my C to understand it but as far as I know TNC serial connects at 38400 baud. As I configured HC-06 to 38400 baud, my pc started to recive the APRS packets that has been decoded by the TNC.

Recieving is perfect but I cannot send packets and transmit it by my Radio. whateven I do I could not get it working. BT module was connected by a voltage divider. Then I used a Logic converter to make sure everything is right on the RX side of the nano but no use.

I tried another Bt modul HC-07 it did not even recieved. RX led on the nano doesnt blink when I transmit. and to make sure I correctly connected BT Rx Tx oposition to Nano hardware serial pins.

I cannot make any sence out of this situation. After hours of research, I checked every problem that has been similar to what I experience and non of the suggestions worked on my bread board.

Finally I gave up and asking you folks about your suggestions since I and internet is out of ideas. Thank you all for your time.

Ps: I even tried to fix the module according to this when it was clear my module was different. (Getting Bluetooth Working with JY-MCU BT_BOARD V1.06 | MCU on Eclipse)

One other hint to make things clearer. I connected HC-06 to PC trough FTDI. While I monitor the FTDI via serial monitor I recived the aprs packet on the monitor. So it means pc to bt serial connection works and data is being sent to arduino but arduino doesnt respond to it. what would be the reason for RX on the nano could fail even with a logic level shifter?


Have you found any solution to this problem? I sent you a PM, I'm having the same trouble. Not sure if you already have figure what's causing this issue.