ATMega2560: Does FTDI work on any RX/TX line?

I built a GPS Clock using an ATMega2560. I used pretty much the same schematic that I’ve used for other projects with ICSP and FTDI headers and they’ve worked fine. However, this time (for no particular reason) I connected the RX and TX lines of the FTDI header to pins 45 and 46 of the ATMega2560 (RXD1 and TXD1).

Whenever I attempt to load a sketch via FTDI, the Arduino IDE or Atmel Studio just time out. If I use my AVRISP mkII programmer with Atmel Studio, I can burn the bootloader and load a simple sketch to blink pin 13. So I know the chip is good. The problem seems to be with the FTDI header. I have RX on the FTDI header connected to TX on the chip and TX on the FTDI header connected to RX on the chip. But it just times out. I’ve used a Mac, a PC, Arduino IDE, Atmel Studio. Nothing seems to “talk” to the chip over FTDI.

My FTDI programmer is good because I just used it on another ATMega2560 project that I made and it worked. However that PCB has FTDI connected to pins 2 and 3. So I’m wondering… does FTDI only work through pins 2 and 3 (RXD0 and TXD0) or does it communicate with the chip on all/any RX/TX ports?

I also attached the pertinent parts of my schematic below…

The FTDI works, but the bootloader looks for data at RxD0/TxD0 and not any other ports.

If this isn't something you can easily change, just use ICSP to program your chip.

Dang. I was afraid of that! Thanks.

Maybe I can rework the board and pull pins 2 and 3 out to the FTDI header. I also tried to set up my Uno as an ISP and try that. That failed too, but knowing now why, it makes sense that it did.

Thanks.

I connected the RX and TX lines of the FTDI header to pins 45 and 46 of the ATMega2560 (RXD1 and TXD1).

You are obviously pretty well verses in circuit design, why on earth would you do that?

(for no particular reason)

Oh, ok :slight_smile:

You caused yourself a world of pain there, guess you won't do that again eh? :slight_smile: Maybe it would be easier to change the bootloader.


Rob

I have no idea. Forest for the trees? I've been working on this clock on and off for about a year. It's like a hobby within a hobby. I guess over time I mixed something up and didn't realize it. At one point I did have an IR receiver in the mix so I could control the clock with a remote control, but I didn't like the way it worked. The IR and GPS libraries didn't play too well together so I ended up ditching the IR receiver in the end. I guess as a result, I ended up hooking up FTDI to the wrong serial port.

These things happen, I won't be telling anyone about my last stuff up, it makes that look like nothing :slight_smile:


Rob