avrdude: no programmer has been specified on the command line or the config file

I was using Arduino Create over the weekend and writing sketches to my Arduino Uno with no issues. I didn't even unplug it. Now I'm getting this error with every sketch I try to upload.

avrdude: no programmer has been specified on the command line or the config file

Specify a programmer using the -c option and try again

You may want to try clearing your browser cache etc as a first step.
Failing that please supply more information as per the post at the top of the forum "How to use this section of the forum"

I am having the same issue as thejaremi. I've read the "how to use..." section and I'll do my best to include the necessary information.

I have the IDE version 1.8.5 running on MacOS High Sierra and am able to upload sketches to my Arduino Uno without any trouble.

I'm running Version 67.0.3396.99 (Official Build) (64-bit) of Chrome.

My USB ports are all 2.0.

The relevant portion of code coming back from the output panel seems to be the following (don't know if I used the code tags correctly or not):

< Flashing with command:/Users/admin/.arduino-create/arduino/avrdude/6.0.1-arduino5/bin/avrdude -
C/Users/admin/.arduino-create/arduino/avrdude/6.0.1-arduino5/etc/avrdude.conf {upload.verify} -patmega328p -carduino -P/dev/cu.usbmodemFA131 -b115200 -D -Uflash:w:/var/folders/6s/l7ydgj7502bfm6rx3yv6f1jm0000gn/T/arduino-create-agent085531789/Chapter2BlinkLED.hex:i

avrdude: no programmer has been specified on the command line or the config file

Specify a programmer using the -c option and try again >

Thanks in advance for any help! I'll check back into the forum in the next day. I can post more of the output panel code if necessary.


This is the CREATE ONLINE EDITOR section.
Are you sure its where you need to be ?


I believe it's where I'm supposed to be, as it is the Create Online Editor with which I'm having trouble, but I'll happily post elsewhere if need be. It's not my intention to hijack a thread or post in the wrong forum.

The downloaded IDE is not being problematic. I've taken sketches which run on it and imported them to the online editor with no changes to the code and verified them (no problems), but they won't upload. I get the "Executing command: exit status 1" message with the aforementioned error in the output panel.

Not sure if this helps or not, but I had the same issue using the Arduino Editor Online to try and load sketches onto my boards today. It had worked fine a few weeks ago when I first tested it. Went to edit the sketch and re-upload today and no go from my Mac. I cleared the browser cache, uninstalled and reinstalled the Arduino Create Plugin, with no luck. I then installed the Arduino Create for Chrome OS on a chromebox I had available, and it worked fine there! I then tried to do it from a Windows Laptop I have and that ran into a totally different error of "an existing connection was forcibly closed by the remote host". Its a test laptop that I had laying around so I'm not too concerned with that error. Hope this helps someone sort out what's going on.


I am also getting this same error message. I was using Create over the week end with no problems but this error message has just started occurring.

I am using a Arduino Mega 2560 on OSX High Sierra

I have tried restarting the computer and clearing the web browser cache.

I have also tried to load the Blink basic example sketch with the same result.

This is the output that I get when I attempt to upload the sketch.

./opt/arduino-builder/arduino-builder -compile -core-api-version 10611 -hardware opt/arduino-builder/hardware -hardware ./opt/cores -tools opt/arduino-builder/tools -tools ./opt/tools -built-in-libraries opt/libraries/latest -logger humantags -fqbn arduino:avr:mega:cpu=atmega2560 -build-cache /tmp -build-path /tmp/948820444/build -verbose -libraries /tmp/948820444/custom -libraries /tmp/948820444/pinned /tmp/948820444/R2D2_Main

Sketch uses 6918 bytes (2%) of program storage space. Maximum is 253952 bytes.

Global variables use 950 bytes (11%) of dynamic memory, leaving 7242 bytes for local variables. Maximum is 8192 bytes.

Flashing with command:/Users/keithbeadman/.arduino-create/arduino/avrdude/6.0.1-arduino5/bin/avrdude -C/Users/keithbeadman/.arduino-create/arduino/avrdude/6.0.1-arduino5/etc/avrdude.conf {upload.verify} -patmega2560 -cwiring -P/dev/cu.usbmodemFA131 -b115200 -D -Uflash:w:/var/folders/ng/3hwtv_m12m7_mw8rthmn2mkh0000gn/T/arduino-create-agent750003197/R2D2_Main.hex:i

avrdude: no programmer has been specified on the command line or the config file

Specify a programmer using the -c option and try again

Any help to resolve this would be very much appreciated.

The problem is caused by this part of the command: {upload.verify}. That's supposed to be used to control the verbosity level.

So if the problem is caused by {upload.verify}, how do I correct this - sorry if this is a dull stupid question but I am not at all sure how to solve this.

I don't think there's anything we can do to fix it. This is one of the problems with cloud-based tools. You have no control over them. You just need to wait and hope the Arduino team will fix the bug soon. In the meantime you can use the standard Arduino IDE, which can be downloaded here:

Many thanks for confirming my suspicion, I'll have to wait for the fix because I am unable to download the desktop version for some reason. Hopefully it will not take too long.

The strange thing is that I added a default definition of {upload.verify} two years ago:

which should ensure we never see {upload.verify} in an avrdude command.

So either Arduino Web Editor is using a super outdated version of Arduino AVR Boards (which it might be since it's using a version of avrdude from over two years ago), or else it's not using platform.txt at all (which would be insane).


I see you are trying to use the dev ed library on a basic blink sketch !

is there a reason for that ?

Do you have that particular board ?

Just to say I am having similar problems with a sketch that compiles and uploads to a Nano on the offline IDE on OSX, but although it compiles (Verifies) on the Safari Web Editir, it will not upload.

I thought at first the lack of an option for Nano old boot loader was the reason for this, as I have to use that option on the offline IDE to upload to my Nano.

I am not certain, but I did think an earlier version of my sketch did upload from the Web Editor a few weeks ago.

Hope that we can get some traction on this, as it is must be affecting quite a few Macintosh users of the Web Editor.

I can of course use the offline IDE for now.

Yes, it was using an outdated version of avr. It should be ok now (try reloading the page to force reloading of parameters)

Thanks for that, it now works here, I am able to select the "old bootloader" option for my nano within the Safari Web Editor and upload my sketch without error.