avrdude: stk500_getsync(): not in sync: resp=0x00

Hello,
Recently I have been getting the error, avrdude: stk500_getsync(): not in sync: resp=0x00 , as I try to upload to my Arduino Uno.

I've been looking around online for a bit and have yet to come across a fix that works, and I've tried many suggestions so far. I've re installed the drives and software, tried resetting before uploading, and I even bought a new Atmega 328 chip (exact same as original, which I also still have). So far nothing has worked.

Also when I've tried resetting, I thought the led's usually blinked, if so, that doesn't happen anymore.

Any help would be appreciated, thanks.

That error actually means: Arduino board not detected at all.

You tried already a lot, but did you try this:

  • Use the right com port (is there more than one ?).
  • Use a different USB port and a different USB cable. Don't use a USB hub.
  • Are you using Windows ? Remove Java from your computer. Download the newest Arduino (1.0.5 at the moment), unzip it in a new folder and try again.
  • Do you use a laptop ? Try a different Operating System (linux or Windows) or try another PC.

Perhaps using a different PC should be the first thing to try. If that works, you can try the other things to try to make it work on your own PC.

If another PC doesn't work, it could be the Arduino boards. You could use a programmer and the ICSP header to check if you still can connect to the ATmega328p chip.

this how i fix my ardunio nano
i had the error in my windows 8 os but when i plug in windows xp it works like charm

what i did i copied required drivers from xp for ardunio and put it on my windows 8 and i used the latest arduino software 1.5.2 and it worked for me. u can try plugging into windows xp check whether it works on that os
this may work

thanks