Blocked when i'm trying to upload any sketch

I’m trying few things whith my new robot arduino (the official) and recently when i try to upload a sketch it blocks at the end of the upload (after the compilation of the code) and i tried a lot of things to fix it but nothing works.
Here are the things i tried :

  • I checked the port and it was the right port
  • I reboot my computer
  • I tried to upload another sketch on a basic arduino board and it works fine
  • I finally waited a long time and it finally said :

avrdude: ser_open(): can’t set com-state for “\.\COM11”
avrdude: ser_send(): write error: sorry no info avail

Voilà i hope the problem can be fixed and that it does not came from my robot !
Thanks for trying to help anyway <3 !

avrdude: ser_open(): can't set com-state for "\.\COM11"

Is the robot actually attached to COM1? Very unlikely.

Nah i’m sure of it this is not a problem of port ^^

Do you attached anything to Reset pin of Arduino.?

Hi,

  • I checked the port and it was the right port

How, do you check the port number?
Do you use control panel, system, device manager, Ports(COM & LPT)…

comports.jpg

Tom… :slight_smile:

Me too, drove me nuts for two days as my win7 laptop worked fine, but a win8.1 did not, but just found a way to fix it. All good.