Bluetooth needs reset to open COM port

Hi

I recently got an Arduino Bluetooth, but i have some difficulties setting it up.

In the Bluetooth Devices settings in Winxp i can see the ARDUINOBT and it has 2 COM ports. It says COM2 is an incoming connection and COM4 is an outgoing connection. In the Arduino program i can see COM2 but i cannot upload a sketch to it. I get a "com2 does not exist or your board is not connected" error. This kinda makes sens because its an incoming connection, but the thing is that COM4 only appears in the tools menu if i first reset the Arduino. Then it works, i can upload programs to the arduino and i can also get some values back if i look at the serial monitor (listening to COM4). I also use a C# .NET application to read from the serial ports, but its the same thing here, i first have to press the reset button on the arduino to be able to open the serial port in the program. Else i just get a time-out error.

It's really inconvenient to have to reset it before i can make a connection, so i hope someone has an idea about what i could be. Could it perhaps be the Bluetooth adapter i use? I am now using a really standard (nameless) bluetooth adapter ...

And does anyone know what's the deal with the 2 different serial connections?

tnx

Erik

hi

we bought 35 of the BT boards here for a class on embodied computing...

There isn't much documentation yet, so I wrote a few tutorials for what we have figured out so far.

The boards work really well, but the bluetooth connection can be finicky. On my Mac, for example, the OS doesn't like it if I turn off hte BT module. Other than that they work perfectly.

From what you say, the problem is within Windows XP or the driver setup. if you can program the board, it is working.

Are you using pin 7 by any chance? Bringing it low resets the BlueGiga module, and you lose Bluetooth.

D

no i'm not using pin 7

i think i might try it with an other bluetooth adapter ( have to go to the shop first )

i'll let you know if it did any good.

i've have tried it with three different bluetooth adapters, but its still not working

could it be something else?

hello e2ther,

because of assigned com ports at windows xp which you are not seeing anymore please read the 'hack 116' on this site: http://www.oreilly.de/catalog/winxphks2/chapter/

Both COM ports are already visible in the windows device manager, but i cannot see the "outgoing" com port from other applications. I tried hack 116 and deleted all the COM ports that were previously invisible, then i installed the ArduinoBT again, with no results. Hack 116 doesn't seem to affect the fact that this com port is invisible in programs other than the device manager. So it only makes it visible in the device manager.

also when i reinstall the bluetoothdevice it only accepts the passkey 12345 when i first press the reset button

i already tried it with a a couple of different bluetoothadapters, on different pc's, and with different ArduinoBT's, but i get the same problem