Board Manager

In the IDE every time I open the Boards Manager it just sits there saying " Downloading Platforms Index......" and can not be cancelled and I have to cntrl alt del to kill the IDE.

I have waited ages just to see if it is a slow net but it never gets to finish.

I think there must be a pointer to a non existing file someplace.

Any help would be greatly appreciated.

Thanks

Stuart

Check your firewall.

I think you might be right.

I haven't got it going yet but I do think you have put your finger on it.

I have turned off all firewalls and once got through with an error in loading the arduino package_index.json but have not been able to duplicate the same error but the change in the problem is enough to make me think you are correct.

Thank you

Sorry no that didn't work I have turned off all firewalls, just to ensure I haven't got a setting wrong and the problem persists.

Could it have anything to do with the fact that I am running Windows Vista ??

Any input greatly appreciated.

Stuart

Do you have any URLs in File > Preferences > Additional Boards Manager URLs?

swharris: Sorry no that didn't work I have turned off all firewalls..

You should be only running one anyway.

Sorry being so long getting back but I have been out of town.

pert,

Yes I have, http://arduino.esp8266.com/stable/package_esp8266com_index.json, however the problem exists whether I have this in the Additional Board Managers or not.

codlink, When I said that I had turned off all firewalls, I normally use Zone Alarm but when I turn that off Windows has a habit of turning its own on, so I mean that I have turned that off too.

With this problem is it possible that the issue is that I am still running on Windows Vista 32bit ?

Input greatly appreciated.

I'm going down this path to install the required board definition for the ESP8266.

Thanks to anyone that helps out.

Regards

Stuart

Well this is completely grasping at straws but maybe the problem could be not with the network but with trying to save to the Arduino15 folder. So you could try creating a folder named portable in the Arduino IDE install folder and then restart the IDE. This will reset your File > Preferences so you will need to add the esp8266 Boards Manager URL again and then give Boards Manager a try, it will install the package to the portable folder instead of the Arduino15 folder. If it doesn't help then just close the IDE and delete the portable folder and you'll be right back to what you had before with your preferences restored to their previous settings.

pert,

Thanks I appreciated that but unfortunately it didn't fix the problem.

I had to start the IDE in Admin mode or it couldn't generate the sketchbook folder .

I had tried renaming the Arduino15 file and regenerating it in the Roaming folder but that didn't fix the problem either.

When I completed your suggestion the systems had not changed one bit.

When I go into Boards Managers only the scroll bar works and nothing else listens to me, to exit I have to cntrl-Alt-Del.

Would love to try another suggestion.

Thanks for all the effort.

Stuart

Pert,

I have taken the 1.6.5 installation file and installed it on my wifes notebook that runs windows 10 and it is working great first time, I was able to load the esp8266 board definition file and select it.

So it appears that all the files I am using and the method employed are correct, it also means that there isn't any strange set up problems with the modem / router which I was starting to doubt.

I really need to be able to do this on my desktop system So I am still open to try any new suggestions.

Regards

Stuart

swharris: So I am still open to try any new suggestions.

Well I know it's far from ideal but would you be willing to do a manual installation of the esp8266 package? I can tell you where to download the files and the folder structure you will need to create.

Yes that would be great,

As a temp solution I had Oracle-VM VirtualBox already installed with Ubuntu and Kali installed within. So I did an Arduino 1.6.5 install on the Ubuntu and the esp8266 board definition loaded fine so I can get around it using the Virtual Machine but I really would like to simplify it by just using the Windows if I can.

If you would provide the files / instructions for a manual install that would be fantastic.

Thank you

Stuart

The easiest way to get the files you need might be to install the esp8266 boards in Boards Manager on your wife's computer and then transfer them to your computer. It won't work to get the files from your Ubuntu machine because there are different tools versions for Linux and Windows. With Arduino IDE 1.6.5r5 and previous they are located at C:\Users(username)\AppData\Roaming\Arduino15\packages\esp8266 which might be in a hidden folder. You can also find the Arduino15 folder by File > Preferences > More preferences can be edited directly in the file. You should also copy over C:\Users(username)\AppData\Roaming\Arduino15\package_esp8266com_index.json in case that is required. The esp8266 Boards Manager URL still needs to be added to File > Preferences > Additional Boards Manager URLs for the boards to appear. If you can't get the files from your wife's computer then you can download them instead but you also need to create the right folder structure for the files so let me know if you need to go with that approach instead.

pert,

Thank you for all of your time.

My Arduino 1.6.5r5 now has all of the boards available that are available on my wifes system, the Boards Manager still fails to load the index but as they are already installed it doesn't make any difference.

It looks like I'm up and running.

Thank you

Stuart

Glad to hear it's working! You can use the same technique to get updated versions of the esp8266 package. It's a shame we couldn't figure out the actual cause of Boards Manager not working on your system, it must be something OS specific.

If I find out I shall come back and tell you in a post.

Thanks again

Stuart

hi Stuart, Pert, I now face the same issue in my PC. And i do not have a backup machine to copy the files from. Can you please suggest a way out? thanks, Madan

pert:
The easiest way to get the files you need might be to install the esp8266 boards in Boards Manager on your wife’s computer and then transfer them to your computer. It won’t work to get the files from your Ubuntu machine because there are different tools versions for Linux and Windows.

I seem to be one of the ones, where the Linux version is destructive the the JSON… I posted this problem elsewhere, and no-one else seems to be able to re-create it…

I run both Windows 8.1 & UBUNTU 16.04LTS_64, the Windows machine doesn’t seem to experience the problem, but all Linux machines seem to blow the json out of the water, If I change the board back to an Arduino, and I’m not connected to the net. Because when I go to the tools > Board: , everything past Arduino UNO WiFi is GONE!! Yet, once I have internet service to the machine, and I go to Tools > Board: > Board Manager, and give it a chance to load the updates, It’s back again! (I’m at a library now, so I just re-activated the files for the ESP12/NodeMCU, but when I go home (where the Internet keeps falling offline (Not hijacking, a shared connection I am authorized to for 2 hours/day, which has been wonky for the past 3 weeks.) , IF I change the board back to the UNO or Duemilinova, or Mega2560, but want to go back to the ESP8266, I’m back to the problem of missing selections under boards.)

Is Anyone else having this problem Under Linux? I cannot see why it is deliberately unloading the ESP board selections, and can only deduce something different between the Linux & Windows versions?