Building a Class - Visual Studio 2012 can't find .h files

Greets! I previously created my own class, and it works fine. I'm trying another and as soon as I create the .h file with a library reference <I2C.h> Intellisense immediately flags red and can't find it!

I'm thinking this may be the way I started to create the class in the first place - I suspect VS is confused about paths...

So - What is the correct way to create a project (or not) in VS 2012 that is destined to become a class/Arduino Library?
Perhaps I shouldn't have started a Project... ?? have tried endless combinations and can't seem the get the existing libraries to show in my #include statements. :fearful:

Has to be a dumb-cluck workflow error as I did it some time ago!

=Alan R.

You don’t use for your own libs it form the libs that came with the system. Use “lib” to access the user created stuff.

Mark

yeah - tried the "" syntax - no go - still VS still can't find it. Must be some other 'secret sauce' for creating an Arduino libary/class with VStudio... :drooling_face:

Thanks for the reply!

=A.

Maybe you looking something like this http://www.visualmicro.com/

Check the PATH settings it may be called PATH or $PATH or CPATH or some thing like that.

Mark