Can’t uninstall library

I have the NTPClient library by Fabrice Weinberg installed and I included it in my current project. When compiling my project I get a “NTPClient: No such file or directory” error, even though the folder exists in the Arduino libraries folder. I decided to remove the folder and reinstall the library hoping that the compiler could find the folder if reinstalled, however, after deleting the NTPClient folder from the libraries folder it still shows up in the list of installed libraries. If I go to ‘Manage Libraries’ and search for NTPClient it shows it as being installed. That leaves me with 2 questions,…

Why is it still listed as installed after the NTPClient folder has been removed from the libraries folder?

How can I reinstall it if the ‘Manage Libraries’ is showing it as already installed?

Anyone?

I assume you are using Windows...

To remove a library, just delete the folder in the libraries folder under arduino. To install a library without using the library manager, go to the github repository and download the archive, like this

Then extract the library's folder and rename it by removing the "-master" at the end. Then copy / paste this folder into your libraries folder.

You must restart the IDE to see the changes, maybe that's why you always see it even if you removed it. In case it doesn't solve, restart your computer.

I decided to remove the folder

Did you delete the folder with the IDE closed ?

My stupidity!!! Not sure how it happened but upon rechecking my code, I noticed that somehow the .h had dissappeared. It was coded as instead of <NTPClient.h>. Thanks to all for your help.

Interesting. In the past, this has always worked. Now I’m running Arduino IDE 1.8.10, and something is different.

I deleted the WiFiNINA library by removing the folder as described. When I restart the IDE and go to Manage Libraries, it shows version 1.4.0 as installed. I needed the older version, so I selected 1.3.0 and clicked Install, and it ran. The folder was re-created in the “libraries” folder as expected, with version 1.3.0. I closed the library manager, and closed the IDE, then rebooted just to be sure. When I restart the IDE and bring up the library manager again, it STILL shows WiFiNina version 1.4.0 as being installed, but the contents of the folder is 1.3.0.

Where is the IDE keeping track of this now???

The Arduino IDE Library Manager has a behavior where if it's unable to write to the default library installation folder name (WiFiNINA in this case), or it determines that it shouldn't write to it (because it thinks the folder contains a completely different library that shouldn't be overwritten), a "fallback" folder name is used which looks like arduino_nnnnn, where nnnnn is a random number. So it might be that you have WiFiNINA installed to one of those arduino_nnnnn folders in your libraries folder.

You can find the location of the WiFiNINA library installation by doing this: File > Examples > WiFiNINA > AP_SimpleWebServer Sketch > Show sketch folder

This will open the examples/AP_SimpleWebServer subfolder of the WiFiNINA library's installation folder.

I'd be interested to hear what you discover. It sounds like an interesting problem.

So... I seem to be having a similar problem.

I wanted to uninstall the LiquidCrystal library. Deleted the folder manually and it still appears as installed. Went to the arduino_xxxxxx folder and theres nothing there. Searched my whole system for an instance of LiquidCrystal and found a folder of it within an Arduino folder WITHIN WindowsApps. When I tried to delete this one, I couldnt because "I require permission from SYSTEM" to do so, despite trying to as Admin.

So... what gives? How can I delete libraries if there is a backup within a folder over which I have no permission?

It's not a backup. The Arduino IDE comes with some common libraries. The reason you can't delete those is because you're using the Microsoft App store version of the Arduino IDE. To provide a higher level of security, Windows is very restrictive of apps. If you want more control, uninstall the Microsoft Store app and use the Arduino IDE downloaded from either the "Windows Installer, for Windows 7 and up", or better yet the "Windows ZIP file for non admin install" links on the Downloads page. It's not immediately, obvious, but those sentences are links that will download the versions of the IDE.

However, there is really no reason you would need to delete this library. If you explain why you are trying to do this uninstall, we can likely help you solve the root issue.