Cannot put Elegoo Uno R3 into DFU mode for UnoJoy


I am having difficulties when I’m trying to put my Elegoo Uno R3 into DFU mode. I am trying to get UnoJoy to work, and it allegedly requires DFU mode to be enabled to work.

I am using the following device:

The problem is that the computer continues to recognizes the device as an Arduino Uno in device manager after trying to enable DFU mode, rather than being an Unknown Device in the manager.

I am using Windows 10.

Any help would be greatly appreciated!


Hard to tell why you need DFU mode.

Its a fairly decent clone and should work as a UNO right from new.
That it is showing up as a UNO is what it should do.

Your other unknown device should have nothing to do with the UNO unless you have installed some driver software that is not applicable to the UNO.

Like I said in my post above, I want to enter DFU mode as it is allegedly required to make UnoJoy work.

By following this video: , I can see that when shorts the two pins his Arduino enters DFU mode as shown in device manager. My Arduino does not enter DFU mode after shorting those pins and it merely disconnects and reconnects itself, so I was wondering why that is and how I could fix that.

Aditionally I have tried to use Atmel’s FLIP, but it cannot find a .dll file (pictures of what I mean attached).

I have tried to fix the error as per video, but I get the following error message:


Cant help you with FLIP.

However that last pic looks like you are trying to tell your computer to use a driver it does not like.
You could disable driver signing and see if that helps but I am of a mind to think that's not the whole issue.

Are you doing these steps with everything disconnected from your board ?

I played with unojoy and even tho installed flip all I had to do was :-

Plug in your board.
Short the two pins , then when computer beeps then click on the "turn into a joystick.bat" file in the unojoy folder.

Hope this helps.