Can't detect the MKRZero?

I just got my MKRZero and installed the SAMD boards and drivers. At first I had the issue that it wouldn't select a port at all, but after looking through the forum I found a post saying that double pressing the reset button fixed it, so I tried, and was able to select the port for the MKRZero (COM4).

However, as I was uploading the sketch, I got an error message saying that no board was detected, and my laptop made the sound it usually does when a USB device gets disconnected, so I tried unplugging it and plugging it in again, at which point it made the sound of a connected device, and I could briefly select a port again before the disconnect sound played and it was greyed out again. I changed USB cable in case it was faulty, but it didn't change anything, and other devices could be connected with those cables, so they are not the issue.

Now it won't even play the connected sound when I try to unplug it and plug it in again. The CHRG light is also blinking intermittently and irregularly, but I don't know if that's normal or not as this is my first time using a MKRZero. Is there some part of the setup that I might have missed, or is it possible that the usb port on the board is broken?

What type of USB ports are you using 1.0, 2.0, 3.0

If its 3.0 swap to 2.0 or insert a POWERED usb 2.0 hub between the Arduino and computer.

Also try another cable JIC it bad or intermittent in any way and dont forget there are TWO types of that particular cable but one only allows charging of devices and not data as well.

As far as the charge light on your MKR thats normal. It will stay on also during charging a LIPO until its is fully charged and then go out.

If you check out the old MKR section (read only) you will find quite a bit of useful info over there. Same with the newer MKR section as a lot still deals with topics you might want to get familiar with.

I also have met some problems. Have you solved the problems? Can I talk about you to this?