RESOLVED - MKRZero stopped being recognized by PC


I got a MKRZero yesterday and I set it up according to the quickstart directions. Everything was working OK so I was playing around with a sketch based on the example weather logger. It was all working as expected but I was doing a lot of small changes and uploads while I was tweaking my program.

After the nth change & upload the board suddenly stopped showing up on the computer. I tried a reset, got the USB device disconnect sound (This is on Win7 x64, BTW) and then nothing happened for about 20 seconds, then the device reconnect sound along with a "USB Device Not Recognized" message.

I tried restarting the computer, using different USB ports and different cables, but I get the same problem. In device manager I get an "Unknown Device" under USB controllers. I tried manually installing drivers from the \arduino\drivers folder, but they wouldn't work either. I also tried uninstalling/reinstalling the SAMD boards from the IDE boards manager.

I also tried another computer with Win10x64, and get a different problem but still can't upload sketches. On the 2nd computer the board gets recognized immediately and has a COM port in the IDE, but when I try to upload it compiles and then hangs at:

Forcing reset using 1200bps open/close on port COM4

If I hit the reset button on the board it moves along to:

PORTS {COM4, } / {} => {}
PORTS {} / {} => {}
PORTS {} / {} => {}
PORTS {} / {COM4, } => {COM4, }
Found upload port: COM4
C:\Users\Rico\AppData\Roaming\Arduino15\packages\arduino\tools\bossac\1.7.0/bossac.exe -i -d --port=COM4 -U true -i -e -w -v C:\Users\Rico\AppData\Local\Temp\build3857720395380208000.tmp/sketch_dec22a.cpp.bin -R

And hangs there indefinitely instead.

Any ideas on what I can do to resolve this? I reached the end of my troubleshooting abilities. :)

Thanks in advance.

Quickly double-tapping the reset buton will usually put into perpetual bootloader mode. I use a pen to tap because my fingers are too big for the little button. Once it is in perpetual bootloader mode it will be recognized as a com port and you should be able to use Tools > Burn Bootloader to restore the board.

That did the trick!

I wasn't able to burn the bootloader, it said I need to select a programmer and none of the options worked (I do have an USBasp, but I didn't try to use it). However, just double tapping the reset button and uploading a sketch like normal worked, and subsequent uploads have worked without a hitch.

Thanks for the help!

Not resolved for me.

I'm running Arduino 1.6.10 on Window 7 and my MKRZero definitely has Reset and USB serial issues. I installed Arduino SAMD (32-bits ARM Cortex-M0+) version 1.6.11 designed to support the Arduino MKRZero board.

Double tapping the Reset button does help get my sketch uploaded and running but sometimes the sketch does not run properly, forcing me to try resetting the board a couple of times before it begins running properly.

Under no circumstances will "Burn Bootloader" work, and sometimes the board re-enumerates and either the port I was running on changes to a different port or it goes away completely forcing me to double tap again to bring it back.

I love the design of the board, but I'm very frustrated with the fact that it is not working as designed: it needs to be fixed.

@ dflyer

Maybe take a wander in the regular MKR section as many of your issues have been covered there first.

I don't own a ZERO but do have a couple of MKR's so the same principles apply.

The dual COM issue is normal in most respects. As far as bootloader I dont have a JTAG programmer so cannot comment but the WIFI101 firmware update did work as described.

I also had the same problem, I have now cured the problem as follows.

  1. Loaded Arduino software onto another PC and burnt an empty sketch to the MKRZero.

  2. Uninstalled SAMD board module from Arduino library manager.

  3. Downloaded USBDeview from web and used to physically remove driver from windows directory.

  4. Reinstalled SAMD board module.

The board has worked correctly since. I hope this helps someone, It definitely seems to be a driver compatibility or corruption problem.


I had the same problem with MKR Fox 1200 and double click reset works for me. Thanks a lot!!

Similar issues here, but finally the problem had been a broken USB cable. So: Consider to use a different USB cable.