Can't program any Arduino

Hello,

Today I wanted to program my Arduino Uno to make use of the LED blink sketch that is included in the examples.
When I upload the sketch i get no errors but the LED doesn't blink.
I've tried these things but with no success:

  • Replace the LED
  • Replace the 220 Ohm resistor
  • Replace the jumper cables
  • Replace the Arduino Uno
  • Replace the USB cable
  • Use another breadboard
  • Tried to use an Arduino Mega instead of an Arduino Uno but gives the same issue
  • Reinstalled and updated the Arduino IDE
// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin LED_BUILTIN as an output.
  pinMode(10, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(10, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);                       // wait for a second
  digitalWrite(10, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);                       // wait for a second
}

I've never had this issue before and it's really holding me back to do anything with the Arduino if I can't even make an external LED blink.
If anyone could help me with this problem, thank you very much :slightly_smiling_face:.

is your LED plugged in the right way? (pin 10 -- Anode [LED] Cathode -- R 220Ω -- GND)

The anode is the one with the "long leg"

Yes, I've made sure that it's in the right position (longest is positive).
Oh is it best to put the resistor before or after the LED?

You are using the breadboard incorrectly. Each line of 5 holes is connected together so
image
all 4 of these connections are shorted, including the LED so no wonder it doesn't blink

gee missed that ! of course

I was about to post the "add some Serial.print()s" advice when I noticed it just in time

1 Like

No one else has ever done such a dumb thing. Cough.

a7

Never.....Cough.. Cough..

"I should have gone to SpecSavers"
Tom... :grinning: :grinning: :grinning: :+1: :+1: :+1: :australia: :australia: