Capacitive sensor library not working

Hi,

I have tried to add the library : http://playground.arduino.cc//Main/CapacitiveSensor?from=Main.CapSense" on arduino v1.0.6 but it is not working..

I have also tried it using previous version arduino 0022 but it is not working.

I badly need it for my project.. please help me :)

First of all Welcome to this forum. "is not working" can be very unclear to others. It helps if: - you tell us what you are using as hardware - show us your sketch so that other may support you in finding a solution

Hello, thank you very much :slight_smile:

I am trying to make a level sensor based on the video:

I downloaded the library zip from: http://playground.arduino.cc/Main/CapacitiveSensor?from=Main.CapSense

however, I am getting the error message (attached) when I try to load the library.

please help me. I have tried it with previous arduino version but in vain.

I am using an arduino uno as hardware.

Arduino forum.png

That is an easy one :grin: library names can only have letters and numbers and underscore symbols. If you rename that library folder name with underscores instead of minus sign you should at least be able to access it.

Thank you :slight_smile:
I have renamed it and it was added to the library. However, when I import it to the sketch, it remains nill (The command ‘#include <CapacitiveSensor.h>’ does not appear on the sketch.

I have also tried the example included (attachment) but the ‘CapacitiveSensor’ part is in black instead of blue.

Do me and maybe someone else a favor and add the sketch complete and a link to the library here online. It is no use to see an error message while there are error messages above. A wrong statement can cause many errors and unfortunately I am not a magicion or fortune teller :grin:

I managed to solve the problem by redownloading the library from https://github.com/PaulStoffregen/CapacitiveSensor

Thank you very much :)

I really appreciate your support and help :)