Code will not compile: "vector: no such file or directory" (ADXL345 Library)

I’ve been working with the ADXL345 from Adafruit lately, and it’s been working perfectly fine; in fact, last week my entire code compiled, but when I began to work on it again today, it refused to run because it could not find the vector file. I’ve been using Adafruit’s custom library for their accelerometer.

I thought it was an issue with the ADXL345 library, but when I checked, nowhere in the code had:

When I looked into the error, it says it’s a mistake within the bno055simplypacketcoms_0_0_2, but I have no idea how I would access it to fix it, or if it’s really an issue within that library.

I’d appreciate it if someone can guide me in fixing this because I’m at a loss.

I ran the example code that came with the ADXL345, and it was pretty much the same error that popped up in my project; this is the error that pops up:

In file included from /home/ubuntu/opt/libraries/latest/bno055simplepacketcoms_0_0_2/src/GetIMU.h:12:0,
from /home/ubuntu/opt/libraries/latest/bno055simplepacketcoms_0_0_2/src/GetIMU.cpp:8:
/home/ubuntu/opt/libraries/latest/simplepacketcoms_0_0_6/src/SimplePacketComs.h:5:18: fatal error: vector: No such file or directory
compilation terminated.
exit status 1

Here's an explanation of the problem and the solution:

Thank you, I really appreciate it!

I'm glad if I was able to be of assistance. Enjoy!