Connecting MKRWIFI1010 to eduroam

Hi, I am trying to connect my Arduino MKR 1010 to eduroam using the WiFiNINA sample code ConnectWithWPA2Enterprise in the library, and I find the input parameters as below:

WiFi.beginEnterprise(ssid, username, password, identity, ca);
Parameters
ssid: the SSID (Service Set Identifier) is the name of the WiFi network you want to connect to.
username: username part of WPA2 Enterprise (RADIUS) credentials
password: password part of WPA2 Enterprise (RADIUS) credentials
identity: WPA2 enterprise identity (optional)
ca: root certificate (string) to validate against (optional)

From the Generic settings for eduroam secure WiFi access on my university, I got the following information:

*Network name (SSID)*
The network name for the secure WiFi network is **eduroam**. This must be all lowercase.

*WiFi authentication and encryption*
The WiFi Network Authentication type is **WPA2 Enterprise**.
The Data Encryption method to use is **AES**.
If your WiFi device does not support WPA2/AES, select **WPA** authentication and **TKIP** encryption.

*User authentication*
The "EAP Authentication Type" or "Outer Authentication Protocol" is **PEAP** or **PEAPv0**.
The "Authentication Method", "Authentication Protocol" or "Inner Authentication Protocol" is **MS-CHAPv2**.
If asked for an "Outer Identity", "Anonymous Identity" or "Roaming Identity", leave it blank.
If asked for a realm, leave it blank.

*Server authentication*
You should choose to **Validate the Server Certificate**.
The certificate should one called **QuoVadis Root CA 2 G3**.

From this information, I can fill in the said (“eduroam”), my username and my password, but I am a little bit confused about the identity and the certificate.

I tried:

WiFi.beginEnterprise(ssid, username, password);
WiFi.beginEnterprise(ssid, username, password, "", "QuoVadis Root CA 2 G3");
WiFi.beginEnterprise(ssid, username, password, "MS-CHAPv2", "QuoVadis Root CA 2 G3");
WiFi.beginEnterprise(ssid, username, password, "WPA", "QuoVadis Root CA 2 G3");
WiFi.beginEnterprise(ssid, username, password, "WPA2 Enterprise", "QuoVadis Root CA 2 G3");

but none of them works.
image

My firmware version is 1.3.0, which should meet the requirement ( this feature requires NINA firmware version 1.3.0 or later) of this library (and that’s also the latest version I can get from the Arduino IDE firmware updater).
image

Does anyone know what the identity and ca are, and how can I fill the parameters in this sample code in order to connect to eduroam?

Have you managed to solve this issue? I'm having the same problem...
From what I could find your identity should be "anonymous@aaaaaaa.bb" where aaaaaa is your university name and bb is your country acronym.
Regarding ca, in my case it is a very long string that you can get from https://eduroam.org/ (just look for your university's certificate).
I've followed the suggestion provided in ESP32-eduroam/WifiClientSecureEnterprise.ino at master · martinius96/ESP32-eduroam · GitHub to format the certificate of my university.

Nevertheless, I'm unable to connect to eduroam. When I run WiFi.beginEnterprise with all the proper parameters (at least I think they are :slight_smile: )it returns WL_NO_SSID_AVAIL, which doesn't make sense, since I have the pc that is powering the MKR connected to that SSID.

Also, I have the latest wifinina firmware, so I can't figure out where might be the problem. Can anyone help us?

I'm using the Uno WIFI rev2 board and running into the same issue. I can connect to my home network alright but when at school the enterprise network seems to mess up the connection. I am using the latest wifiNINA firmware, have the
status = WiFi.beginEnterprise(ssid, user, pass);
syntax with an arduino_secrets.h page. I have my school's private wifi as well as and eduroam option. I can log on to both no problem on a phone or laptop but by arduino board is stuck looping "trying to connect to ssid" seems like it never gets to the username part. I guess I have no answers but I too would love some help!