Deek-robot datalogging shield v1 on mega2560

I ran out of ram using a UNO and upgraded to MEGA2560 to resolve the memory issue but now the sdcard shield that worked on the UNO does not work on the MEGA

The most common cause of this is that the Uno has the SPI bus broken out to pins 11, 12, 13, but on the Mega they are at 51, 50, 52. A properly designed shield will make the SPI connections on the ICSP header, which allows it to be compatible with all Arduino boards, but some older or poorly made shield designs don't do this and so are not compatible with the Mega (and Leonardo too).

Posted just now

I separated the shield from the MEGA2560 and wired direct and all worked well. I thought I would clip the leads causing the conflict so I could use the shield as intended. Only problem now is it works with the pins 10,11,12,13 connected to 53,51,50,52. Thanks to all who assisted. I can now continue with the project.

I'm glad to hear it's working now! Thank you for taking the time to post an update with your solution.