DFRobot L298 motor shield and stepper motor doesn't work

Hi, i hope somebody can help me with this

I have a DFRobot 2A Motor shield (http://www.dfrobot.com/wiki/index.php?title=Arduino_Motor_Shield_(L298N)_(SKU:DRI0009))
I want to connect a stepper motor to it (http://www.pieterfloris.nl/shop/product.php?id_product=120)

i connected it to a 12 V 0.38 A power supply

Now when i run this simple sketch

#include <AFMotor.h>


AF_Stepper motor(200, 2);


void setup() {
  Serial.begin(9600);           // set up Serial library at 9600 bps
  Serial.println("Stepper test!");

  motor.setSpeed(10);  // 10 rpm   

  motor.step(100, FORWARD, SINGLE); 
  motor.release();
  delay(1000);
}

void loop() {
  motor.step(100, FORWARD, SINGLE); 
  motor.step(100, BACKWARD, SINGLE); 

  motor.step(100, FORWARD, DOUBLE); 
  motor.step(100, BACKWARD, DOUBLE);

  motor.step(100, FORWARD, INTERLEAVE); 
  motor.step(100, BACKWARD, INTERLEAVE); 

  motor.step(100, FORWARD, MICROSTEP); 
  motor.step(100, BACKWARD, MICROSTEP); 
}

it does nothing but tremble a bit.
it seems to follow the instruction (as there are LEDs blinking and delays) but it doesn’t rotate.

I tried a 15 V 0.8 A and a 12 V 2.5 A, but no difference

Anybody has an idea?

That shield uses different pins to the Adafruit motor shield, and the AFMotor library you are using.

Try using the AccelStepper library instead:

http://www.open.com.au/mikem/arduino/AccelStepper/

As the previous poster said, AF_Stepper is only for the Adafruit motor shield.

-- The Rugged Audio Shield: Line In, Mic In, Headphone Out, microSD socket, potentiometer, play/record WAV files

thanks

i tried the accelstepper library but unfortunately this didn't work either.

same problem: just jagging, no turning

if anybody could tell me this motor shield should work (which according to some posts on the web should, but i am still not to sure) i would be very happy.

Thanks for the help

it seemed that my motor shield was broken (no idea how that might have happened) but after i bought a new one, all things wored smoothly

w