Duemilanove + MaxMsp = Broken?

Hi, We just bought 10 Duemilanove Arduinos to use as show controllers for installations. The chip on those is the ATmega 328. We use it to receive a push button on pin 10 to start a show built in Max. I use Maxuino004 to read the serial command. When I first uploaded the Firmata v1 on it it worked fine but after a while, the board became completely unresponsive. We went through 4 boards. They all stopped working about a week after the exhibitions started. I made some experiments and it seems to work only if, after opening the max patch, I push the Arduino's reset button. If I upload simple patches (blink, Button...) they work perfectly well. It seems that only the serial part of the Arduino is broken... I tried with different "protocols" (simple message, messenger...) to no avail. What is strange is that I used the Diecimila for the exact same setup with no problems in two years of continuous use.

Setup: Arduino Duemilanove ATmega 328 Arduino 015 Mac Book 2.0GHzIntel Core 2 Duo; 2GB DDR3 Memory; NVIDIA GeForce 9400M OSX 10.5.6 Maxuino 004 (Firmata 1) MaxMSP 5.0.7

Any ideas?