Elechouse VR3 Module Timeout

No matter what I do, every time I run the VR sample train example code included in the VR3 voice recognition library I get the same error message when I try to input commands on the serial monitor. I haven't changed the code and there are no problems with the VR3 module, the breadboard, and the Arduino Uno board themselves. I am not sure how to solve this problem. I've already looked at multiple links to others with the same issue yet all of the solutions given have not worked for me. Attached is an image of my setup and the sample code can be found by downloaded this: VR3 Library Zip.

Setup: VR3 Hardware Module Setup

Begin by quoting the error message so others can enjoy seeing it.

Sorry about that, I completely forgot to attach this image.

And the error message you referred to is what?

When I type in a command like "train" or "settings", it always says "check system settings error or timeout". I'm not quite sure how to fix it.

Do other sample programs work?

It's weird, some examples work but specific ones don't. There is an example written that allows me to check the baud rate on the module and that works well, but any example that has the purpose of recording something using the module does not work.

Voice Recognition Module v3.1, multi language commands training “speech recognition,Arduino Tutorial - YouTube

Here is a video of what the module should be able to do. In the video you can see that the LED on the module is blinking, and every time I upload the example code to the Arduino board, the LED of the module remains unchanged. I don't know how else to debug because I didn't change the code and I know the module can work. What do you suggest I do next?

VR3_manual.pdf (elechouse.com)

Here is the manual to the module I am using. My issue regards the vr_sample_train.

I was able to get the module to be recognized by my PC by changing the baud rate that the module uses. For example, in the setup of every example they have a line that sets up the baud rate for the module:

myVr.begin(9600); //9600 is the baud rate

Based on the example that shows me the baud rate of the module, I changed it to 19200 and the LED began blinking like it is supposed to, but I still get the same timeout issue.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.