Epaper Problem on MEGA2560

Hey Everyone,

I am trying to set up an Arduino Mega with a Seeed Studio E-paper shield, but no matter what I do, the only thing I can get on the screen are these weird horizontal and vertical stripes:

Right now I'm testing with Seeed Studio's official example code on Github, but I can't even clear the screen.

First I tried with an additional E-Paper (as seen on the picture), then with another E-paper shield, but that still didn't solve the problem :S My Arduino Mega works perfectly for any other task, so that shouldn't be the problem either.

What could be the problem here? Is there something wrong with the official example code? Or what else could be wrong?

I would be forever grateful for any assistance

Hello,

I´m trying to use Seeed Studo e-paper arduino uno. I got a text example at official git hub.
In my case I got this error " ePaperDfs.h: No such file or directory
#include "ePaperDfs.h""

Do you know how can I handle it?

thanks

You need to download and install the library 'ePaperDfs.h'. Either that or you have installed it in the wrong place.

Hi dannable,

Yeah, It is the problem.

I found the ePaperDfs.h but not ePaperDfs.cpp, so I can´t upload library without this file.

Do you have any idea?

Hi Erica,
Did you solved this? I have same problem.
Regards,
Laszlo

dears
i have the same issue with my shield . i have seeed shield and panal EM027AS012
any ideas
thanks in advance

Hi BlueFox,

Did you get a solution for your issue?

I was getting similar issue when I was trying to use with UNO R3. But When I updated the library it worked fine.

On Mega 2560, nothing works for me. I am surprised to see how are you getting those lines.

If you have found a solution please share.

Atleast share how did those lines appear for you.

I am using the below shield: