Error building new OpenWRT-yun image

Hey all, has anyone tried building the OpenWRT-yun image (from https://github.com/arduino/openwrt-yun ) for the recently released firmware? I gave it a shot on my Ubuntu 12.04 LTS system and it failed after making zlib. Here's the output I see:

make[3]: Leaving directory `/home/tony/Repositories/openwrt-yun/package/zlib'
make[2]: Leaving directory `/home/tony/Repositories/openwrt-yun'
make[1]: *** [/home/tony/Repositories/openwrt-yun/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/tony/Repositories/openwrt-yun'
make: *** [world] Error 2

Anyone else run into a similar error, or have pointers on what to debug next? Thanks!

make package/zlib/clean
make package/zlib/compile V=s

Use V=99:

make package/zlib/compile V=99

If @sonnyyu advice doesn't suffice, please attach the whole compilation output, not just the final lines. The actual error message is much more up in the log. What you pasted is just telling "there was an error and now I'm quitting"

Zlib is actually compiling successfully, I think whatever happens immediately after zlib is what's failing. Is zlib the last package? (I'm guessing so based on its name) What happens after all the packages are compiled? I tried to follow the OpenWRT makefiles but they're rather complex so it's a little tough to see exactly what's happening. These lines make me think it's something immediately after the packages that's failing, but no output is showing what the error is:

make[2]: Leaving directory `/home/tony/Repositories/openwrt-yun'
make[1]: *** [/home/tony/Repositories/openwrt-yun/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile] Error 2

Tried the lines suggested by sonnyyu, but it seems to fail in the same spot. Here's as much of the output as I could copy: http://pastebin.com/9BCVW2PH

Thanks for the help so far!

Try again using the recovery command https://github.com/arduino/openwrt-yun#recovering together with nohup

MAKE_JOBS=5 nice -n 10 nohup make -j $MAKE_JOBS V=s &

This will create a nohup.out file with all the output. You can see what's going on with

tail -f nohup.out

Once terminated, please, upload the file somewhere so we can read it

Thanks, here’s the file attached. I grep’ed around for error or similar strings and see this on line 4107:

4107:configure: error: GPGME 1.0.0 or later needed

It seems to go on and finish building ubus so I’m not sure if that’s the issue. Let me know if you see anything, thanks!

nohup.out.zip (224 KB)

I agree the error should be that one, but I would ask you to make another try. Delete file nohup.out, then re run with

nice -n 10 nohup make -j 1 V=s &

This will force each package to be built one after the other, without mixing logs. This way the last error message will be the right one. Sorry for the ping pong of requests: I'll update the readme and add a troubleshooting section

Troubleshooting section added https://github.com/arduino/openwrt-yun#troubleshooting

if you get source code by:

git clone https://github.com/arduino/OpenWrt-yun.git

http://forum.arduino.cc/index.php?topic=235489.msg1699935#msg1699935

start over again.

Oh I did clone the repo using SSL instead of the private/public key stuff. Perhaps that is the issue, I'll check out that thread and give it a shot. If it still fails I'll trying running what you suggested Federico. Thanks!

I have a feeling that was the problem and it's fixed. It's been compiling for a few hours now, which is longer than it ran before. Will update when it's done, but I think it's going well.

Yep that worked perfectly! Very cool, nice to have such a complex build be so easy. I'll send a pull request to update the README for the repo with this note.

Two catch of using “github.com” private/public key stuff:

  • Instead of to use hardware PKCS #11 tokens or smart card to store private keys but use file system to store private keys which is very unsecure.
  • Not utilize PKI (public key infrastructure) which allow single sign on with out pre-binding public key with “github.com”.