Error message when uploading sketch

Installed the board and selected it.
I tried several sketches, and it did run them.
Upload was quasi OK!

When I tried in:

void setup() {

Something like:

lcd.setCursor(1, 3);
lcd.print("Start...");

//while (!Serial);

BLEDevice central = BLE.central();
if (central) {
String address = central.address();
// Serial.print("address is: ");
// Serial.println(address);
lcd.setCursor(1, 2);
lcd.print(address);
}

I actually wanted this and changed the file

String address = BLE.address();
lcd.setCursor(1, 2);
lcd.print("address");

Upload has never succeeded anymore!

Made also the error to set this under comment
//while (!Serial);
so it is trapped over and over...

It looks like the board get stuck, and it wouldn’t let me download any sketch,
not the simplest like

void setup() {
// Serial.begin(9600);
// Serial.println("Oops ... a rp2040");
}

I only receive the following:

Sketch uses 82548 bytes (0%) of program storage space. Maximum is 16777216 bytes.
Global variables use 54164 bytes (20%) of dynamic memory, leaving 216172 bytes for local variables. Maximum is 270336 bytes.
..........................................
An error occurred while uploading the sketch

Hi @mslndr. You can try the techniques described here to recover your board:

Thanks.
2. ... jumper wire between the REC and GND pins ...
3. ... (even though it is not visible in the port selection) …
Sketch blink
5.This means it is successful!

A test sketch can be uploaded, modified and uploaded again … OK!

But once I use ArduinoBLE libraries …
like:

#include <ArduinoBLE.h>
....
void setup() {
....
BLE.begin();
String address = BLE.address();
Serial.print("Local address is: ");
Serial.println(address);
....

It gets stuck as before, and the reset like above 2.,3.,5., is necessary

Is there a way out?

This is progress, even if it doesn't look much like it.

Does the same problem occur if you upload one of the example sketches of the ArduinoBLE library?

Do you have the latest version of the library installed (1.2.1)? You can check in the Arduino Library Manager (Sketch > Include Library > Manage Libraries...) to see which version you have installed.

Do you have the latest version of the "Arduino Mbed OS Nano Boards" platform installed (2.3.1)? You can check in the Arduino Boards Manager (Tools > Board > Boards Manager) to see which version you have installed.

Thanks

Arduino Mbed OS Nano Boards
by Arduino version 2.3.1 INSTALLED

ArduinoBLE
by Arduino Version 1.2.1 INSTALLED Enables BLE connectivity on the
Arduino MKR WiFi 1010, Arduino UNO WiFi Rev.2, Arduino Nano 33 IoT, and Arduino Nano 33 BLE. This library supports creating a BLE peripheral and BLE central mode.

/*
Scan
This example scans for BLE peripherals and prints out their advertising details:
address, local name, advertised service UUID's.

The circuit:

  • Arduino MKR WiFi 1010, Arduino Uno WiFi Rev2 board, Arduino Nano 33 IoT, Arduino Nano 33 BLE, or Arduino Nano 33 BLE Sense board.

This example code is in the public domain.

*/

19:56:13.688 -> starting BLE failed!

code part:
// begin initialization
if (!BLE.begin()) {
Serial.println("starting BLE failed!");

while (1);

}

Apropos:
WiFiNINA firmware version 1.4.7 is now installed...

I have to finish now until tomorrow, ciao

Hallo,

I still have no solution!

On the forum is another issue with arduino-rp-2040-bluetooth.
...trying to connect my mobile phone to the soldered Bluetooth module on the RP2040 ...
[Arduino RP 2040 Bluetooth]

I don't know if it's a Nano RP2040 Connect, but it opens ArduinoBLE connections fine.

In the Tech Specs is written [Arduino Nano RP2040 Connect] the connectivity chip is via Bluetooth Nina W102 uBlox module and the Wi-Fi Nina W102 uBlox module.

I had to upgrade WiFiNINA firmware because Wifi wouldn't work ... I just bought it on 15.7.2021 (with already soldered pins)

16:57:24.290 -> WiFiNINA firmware check.
16:57:24.290 ->
16:57:25.010 -> Firmware version installed: 1.4.5
16:57:25.010 -> Latest firmware version available : 1.4.7
16:57:25.010 ->
16:57:25.010 -> Check result: NOT PASSED
16:57:25.010 -> - The firmware version on the module does not match the
16:57:25.010 -> version required by the library, you may experience
16:57:25.010 -> issues or failures.

Since then I can use Wifi successfully.

Can it be possible that the connectivity chip's latest firmware update could cause my problem, or can this chip partly be broken?

Now I downgraded WiFiNINA firmware,
Firmware version installed: 1.4.5,
and it opens ArduinoBLE connections fine.
I also can use Wifi successfully, even with "Check result: NOT PASSED".