Error when upload a simple blinking code to Arduino Uno

Hi, I have a problem uploading a simple LED blinking code to my Arduino Uno. Just yesterday everything is OK. I am very sure my code is no problem as I tried it many times below. Below is the error message:

D:\Setup Files\Arduino IDE\arduino-1.8.13-windows\arduino-1.8.13\hardware\tools\avr/bin/avrdude -CD:\Setup Files\Arduino IDE\arduino-1.8.13-windows\arduino-1.8.13\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM6 -b115200 -D -Uflash:w:C:\Users\Acer\AppData\Local\Temp\arduino_build_898351/testing.ino.hex:i

An error occurred while uploading the sketch

avrdude: Version 6.3-20190619

Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "D:\Setup Files\Arduino IDE\arduino-1.8.13-windows\arduino-1.8.13\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM6

Using Programmer : arduino

Overriding Baud Rate : 115200

Below are the steps I have tried:

  1. Program with different Arduino Uno.
  2. Uninstall and reinstall the same version of Arduino IDE.
  3. Uninstall and reinstall the different versions of Arduino IDE.

However, the problem still exists. Appreciate your help to solve my problem.

reboot the PC
open an empty window (with the basic empty setup() and loop() sketch)
plug in your Arduino UNO with NOTHING connected but the USB wire
ensure you select the right board's type
ensure you select the right Serial Port
try uploading

  • change the USB port
  • change the USB cable

do you have the issue regardless of the Arduino you try or does it work for some?

General tips for the forum.

Could you take a few moments to Learn How To Use The Forum.
It will help you get the best out of the forum in the future.

  • Your OS and version can be valuable information, please include it along with extra security you are using.
  • Always list the version of the IDE you are using and the board version if applicable.
  • Use quote or add error messages as an attachment NOT a picture.
  • How to insert an image into your post. ( Thanks @Robin2 )
  • Add your sketch where applicable but please use CODE TAGS ( </> )
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can

COMMON ISSUES

  • Ensure you have FULLY inserted the USB cables.
  • Check you have a COMMON GROUND where required. ( Thanks @Perry)
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102
  • There may be a problem with the board check or remove your wiring first.
  • Remove any items connected to pins 0 and 1.

COMPUTER RELATED

  • Close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent

ARDUINO SPECIFIC BOARDS

  • CH340/341 based clones do not report useful information to the “get board info” button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (ALL Types) See the specific sections lower in the forum.
  • NANO (NEW Types) Install your board CORE’s.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.
  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/ArduinoCreateAgent.app/Contents/MacOS/config.ini
  • On Linux ~/ArduinoCreateAgent-1.1/config.ini
  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.
Language problem ?
Try a language closer to your native language:

Thanks to all those who helped and added to this list.
[/quote]

Yes, what you suggested I had tried, but the problem still exists

I have 3 pieces of Arduino Uno, three of them face the same problem. I Had change the USM port and cable, problem still exists

Do you see their port in the IDE ?

Hi J-M-L

I have solved the problem. The reason I cannot upload because my Bluetooth module is occupying COM6 while my Arduino Uno also using COM6. After I turn off my Bluetooth module, the problem is solved. Thank for your previous reply.

Great (weird they end up on sale port)
Have fun

Thank you