Esp32 does not work with Arduino IOT Cloud when disconnected from pc

Hi,

I am trying to use esp32 board with Arduino IOT Cloud.
What I observed is if I connect the esp32 board with laptop using usb cable , it works properly and I can control GPIO pins successfully (I am using relays at output).
However if I disconnect esp32 board from laptop, and provide power externally , it does not work . Even if change the switch status from dashboard, esp32 does not change the pins status.
Could you please help ?

Which ESP32 model are you using and what are the connections with the external power and relays?

Is the ESP32 device actually correctly powering up and connecting to the cloud? I know some issues I've had were related to the power supplied to the unit, too much mA, etc.

It worked !!

Thanks guys for taking a look into this issue .
Eventually the issue was with power provided to esp32.
Somehow the breadboard was faulty and causing voltage drop. I was supplying 5 V power through vin pin of esp32 (38 pins module) connected on breadboard. when I measured the voltage across vin and gnd it was below 4.5 volts and that was causing issue .

I changed the breadboard and voltage was near 5 V and all worked!!!

I always check power supplied to the devices but this time never thought a breadboard also can cause serious issues.
learning from this issue "Always always pay attention towards power supplied to the devices no matter what" :slight_smile: