Exit Status 1, Error compiling for board Arduino Uno

In file included from C:\Users\admin\Desktop\arm\arm.ino:1:0:
Multiple libraries were found for “HCPCA9685.h.h”
C:\Users\admin\Documents\Arduino\libraries\HCPCA9685/HCPCA9685.h.h:24:10: fatal error: HCPCA9685.h: No such file or directory
Used: C:\Users\admin\Documents\Arduino\libraries\HCPCA9685
#include “HCPCA9685.h”
Not used: C:\Program Files (x86)\Arduino\libraries\HCPCA9685
^~~~~~~~~~~~~
compilation terminated.
exit status 1
Error compiling for board Arduino Uno.

  • i am trying to built a robotic arm using arduino…

I have been trying to upload the code’s to my arduino uno board, but it could not seem to upload. " Error compiling for board Arduino Uno " kept on popping up, i have tried uploading the library that is needed… and it already said that the library is uploaded… but this sign kept on popping up, i dont know why… could anybody help me please? Thank You

That, usually, means that the library was not installed properly. How did you install the library?
The best way to install a library is using the IDE library manager if the library is available in the library manager. Go to the libraries folder in your sketchbook and delete all the other libraries with that name and install the new one.

See also Installing Arduino libraries.

i copied the codes and downloaded the zip file from github… i uploaded it using the " add .zip libraries "

ive tried deleting and downloading it again, but now i could not upload it to the library… whenever i try to reupload it the sign " error in opening zip file "

Invalid library found in C:\Program Files (x86)\Arduino\libraries\HCPCA9685.h: no headers files (.h) found in C:\Program Files (x86)\Arduino\libraries\HCPCA9685.h
Invalid library found in C:\Users\admin\Documents\Arduino\libraries\HCPCA9685: no headers files (.h) found in C:\Users\admin\Documents\Arduino\libraries\HCPCA9685
Invalid library found in C:\Program Files (x86)\Arduino\libraries\HCPCA9685.h: no headers files (.h) found in C:\Program Files (x86)\Arduino\libraries\HCPCA9685.h
Invalid library found in C:\Users\admin\Documents\Arduino\libraries\HCPCA9685: no headers files (.h) found in C:\Users\admin\Documents\Arduino\libraries\HCPCA9685

could you please help me?

Where are you finding that library? I am having no luck finding it with a Google search.

Are you following a tutorial or instructable page? Can you post a link to it?

Does it have to be that exact library? There are several libraries for the PCA9685 board in the IDE library manager. Those libraries are more likely to be current and actively maintained.

its this one…

i think it has to be that exact library, because i have tried using other PCA9685 library… and none of them worked…

this is the code link…

i dont know what is the problem…

The problem is that on that page there is no library, just the programs for the robot.

Nowhere in that link is the actual library code. I have searched for the library and always get sent to this page. I even went so far as to register with the site to be able to download the library but was denied.

Then I tried another search and found this page. From there I was able to download a zip file of the HCPCA9685 LIBRARY. Once downloaded i went to the IDE and installed the library with the Add .Zip library. It installed successfully. I even loaded one of the examples from the library and compiled the example with no problems.

Hope that works for you.

1 Like

THANK YOU SO MUCH!! it worked… i could not have done it without your help… you are my life saviour!! i could not thank you enoughh!!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.