Fingerprint Sensor (R503) not working

I am having issues with activating adafruit fingerprint sensor
Rugged Panel Mount Fingerprint Sensor with Bi-Color LED Ring (R503) [/b]

Wired as instructed
Red 3v
Black gnd
Green Tx
White Rx

arduino Uno & R503 fingerprint sensor by adafruit

The sensor doesn't blinks at all at any time

After uploading the adafruit enroll get a message

adafruit did not find fingerprint sensor :(  

soldered sensor wires to thicker male pins wires to insert to a board and tested for continuity - rings ok - and the
micro controller is ok as well tried to power cycle by disconnecting / reconnecting the 3v and the arduino as well
what else should I try? or the sensor is defective?

Thank you everybody!

Do you have Green connected to Pin 2 and White connected to Pin 3?

// For UNO and others without hardware serial, we must use software serial...
// pin #2 is IN from sensor (GREEN wire)
// pin #3 is OUT from arduino  (WHITE wire)
// Set up the serial port to use softwareserial..
SoftwareSerial mySerial(2, 3);

yes... same...

when I started I had similar problems with my NodeMCU 8266.
For me it worked after setting the PinMode for the RxD/TxD Pins

pinMode(D2, INPUT);  /* RS232 RxD */
pinMode(D3, OUTPUT); /* RS232 TxD */

Good luck

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.