Firmware Update 1.1.0 - available now (with source code)

Hi everyone,
I'm very glad to announce that the new firmware for our beloved Nina W102 module is available!

How to get it (fast and lean):

  • Download the hourly version of Arduino IDE (from https://www.arduino.cc/en/Main/Software#hourly)
  • Update WiFiNINA library to version 1.2.0
  • Upload FirmwareUpdater example (under Tools subfolder) to your MKRWiFi1010 or MKRVidor4000
  • From Tools menu, open WiFi101 / WiFiNINA Firmware Updater
  • Select the right serial port and click Update Firmware. Done!

A quick overview of what you get with the new update:

  • A huge list of root certificates so in most cases SSL works out of the box
  • The ablity, using the same upload tool, to add your own certificate
  • Improvements in automatic power saving
  • Improvements in scan accurancy
  • The source code of the firmware (GitHub - arduino/nina-fw: Firmware for u-blox NINA W102 WiFi/BT module) is now available for study, hacking and contributions.

Other links: GitHub - arduino/WiFi101-FirmwareUpdater-Plugin: WiFi101 Firmware Updater Tool for Arduino IDE contains the source for the new updater.
Pro tip: if you want to add the new updater to an older installation of the IDE without downloading the nightly, download this file and extract it to your sketchbook folder.
After restarting the IDE you can use the new entry under Tools menu to perform the update.

I have tried it and it has not worked. See comments on the issue in github

lsaetta65:
I have tried it and it has not worked. See comments on the issue in github

Can you add a link directly to the issue please ?

Also did not work for me either with 1.8.6 - 1.8.7.
Managed to get the FW updater sketch into the 1010 with 1.8.5 after dropping it in as facchinm suggested but still seem to be hitting a stumbling block once I try to TEST CONNECTION.

More info to follow…

SAMD core 1.6.19
IDE 1.8.7

Just sits on uploading with the bar almost finished.
This 1010 had been set for CLOUD use :wink:

If I compile only it does so just fine.
If I then try to re-upload the FW update sketch I occasionally get the following.

Arduino: 1.8.7 (Windows 7), Board: "Arduino MKR WiFi 1010"

Sketch uses 13072 bytes (4%) of program storage space. Maximum is 262144 bytes.
Forcing reset using 1200bps open/close on port COM34
processing.app.debug.RunnerException
 at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:160)
 at cc.arduino.UploaderUtils.upload(UploaderUtils.java:82)
 at processing.app.SketchController.upload(SketchController.java:736)
 at processing.app.SketchController.exportApplet(SketchController.java:703)
 at processing.app.Editor$DefaultExportHandler.run(Editor.java:2028)
 at java.lang.Thread.run(Thread.java:748)
Caused by: processing.app.SerialException: Error touching serial port 'COM34'.
 at processing.app.Serial.touchForCDCReset(Serial.java:107)
 at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:144)
 ... 5 more
Caused by: jssc.SerialPortException: Port name - COM34; Method name - openPort(); Exception type - Port busy.
 at jssc.SerialPort.openPort(SerialPort.java:164)
 at processing.app.Serial.touchForCDCReset(Serial.java:101)
 ... 6 more
An error occurred while uploading the sketch
Exception in thread "Thread-18" java.util.ConcurrentModificationException
 at java.util.LinkedList$ListItr.checkForComodification(LinkedList.java:966)
 at java.util.LinkedList$ListItr.next(LinkedList.java:888)
 at processing.app.packages.LibraryList.getByName(LibraryList.java:61)
 at cc.arduino.contributions.libraries.LibrariesIndexer.addToInstalledLibraries(LibrariesIndexer.java:130)
 at cc.arduino.contributions.libraries.LibrariesIndexer.scanLibrary(LibrariesIndexer.java:229)
 at cc.arduino.contributions.libraries.LibrariesIndexer.scanInstalledLibraries(LibrariesIndexer.java:201)
 at cc.arduino.contributions.libraries.LibrariesIndexer.rescanLibraries(LibrariesIndexer.java:161)
 at cc.arduino.contributions.libraries.LibrariesIndexer.setLibrariesFolders(LibrariesIndexer.java:120)
 at processing.app.BaseNoGui.onBoardOrPortChange(BaseNoGui.java:678)
 at processing.app.Base.onBoardOrPortChange(Base.java:1313)
 at processing.app.Editor$DefaultExportHandler.run(Editor.java:2058)
 at java.lang.Thread.run(Thread.java:748)

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

UPDATE.

Sometimes doing the DOUBLE TAP RESET will allow me to get the sketch in using the newer IDE’s

The NIGHTLY IDE ?> 1.6.10 <? Gives the following on running it from its extracted folder.

Error downloading https://dl.espressif.com/dl/package_esp32_index.json

Should there not be a “fallback” URL ?

Along with quite a few “Ignoring sketch” warnings for 1010 sketches ! :o

Ok, gentlemen. It has worked for me, thks to kind help from @facchinm. MY problem was that I had upgraded WiFINIna to 1.2 before and therefore I hadn't in Wifinina dir the right firmware updater sketch.

Workaround suggested: delete the directory for WiFINIna under library.
Reinstall the WifiNIna, ver.s 1.2
Install the right (for WifiNIna) Firmware UPgrader Sketch
Upgrade the firmware.

great.

Thanks for that lsaetta65
Karma for follow up.

Confirmed. I had the same problem as @Isaetta65. I had previously upgraded to 1.2 and it showed the wrong firmware (winc b something) even though I updated the library manager's wifinina to 1.2 from 1.1.

Removed the libraries\WiFiNINA .... replaced hourly build... downloaded 1.2 again... and the upload of Examples\WiFiNINA\Tools\FirmUpdater ... then ran WiFiNINA Firmware Updater.

Thanks!

Q. Is there a simple "check firmware" sketch available just for the 1010 ?

We don't have one now, but if you ask nicely on Github we can add :slight_smile: Pull requests also welcome for one ...

@ballscrewbob

It already somewhat exists in the example “ConnectWithWPA” as well as others.

Just change…

  String fv = WiFi.firmwareVersion();
  if (fv < "1.0.0") {
    Serial.println("Please upgrade the firmware");
  }

to…

Serial.println(WiFi.firmwareVersion());

In setup. It’ll show you on serial monitor.

-drr

Hi all,

I recently bought a MKR1010 and used it successfully with the WifiNina library. Nice board!
When I decided to come to Adafruit IO, I experienced all the problems you had but discovering this post and some others, I was happy to get the solution.

So, I did:

  • uninstall totally IDE 1.8.7 version
  • download hourly BUILD 1.8.7
  • import last 1.2 version of WifiNina library with the library manager
  • load the Firmware updater sketch
  • launch the WiFi / WiFiNina Firmware/certificates updater
  • the COM port is the good one
  • the Nina Firmware version is 1.1.0

And I have a problem: "Programmer not responding"

I must add that I can successfully load the Blink example before AND after the problem. The COM port is running well.

A screen copy behind this link shows the message

https://drive.google.com/file/d/1m0U8rRBKqFEpyAHs7UXB9tdrZwJ4Rd7t/view?usp=sharing

Any help woul be much appreciated
Regards

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.