Forum Help - Permanently useless?

I only joined the forum about a week ago. When I ask for Help, it says it is down but will be back in a minute.

Is the minute of infinite length?

When you do what? Click the Help link in the upper-right corner?

Yeah, not too helpful.
There’s another link on the help page that takes you to the main arduino page.

Not nearly as helpful as us in the forum.

Yes, the button between "Profile" and "Sign Out".

The button that takes me to the page that says "Dude, we are populating our help server." (Or words to that effect.) and then says to come back in a minute.

The button that I expected would tell me all about the rules of the forum and explain the workings of the myriad of buttons on the posting page.

Rules used by the moderators... http://arduino.cc/forum/index.php/topic,54857.msg392814.html#msg392814

Buttons and posting information is here... http://docs.simplemachines.org/index.php?board=5.0;sort=subject

Using Google to search for whatever + "SMF" or "Simple Machines" is also a good way to find usage information.

When posting code, please use [code] [/code] tags. The # button above the edit window inserts a pair or you can enter them yourself.

If you need further assistance, you can always send a Personal Message to a moderator.

PeteC: The button that takes me to the page that says "Dude, we are populating our help server." (Or words to that effect.) and then says to come back in a minute.

I reported that months ago. That's one looooong minute!

Maybe that's why the forum's so slow ....

That's a long minute.

This button leads to that:

The picture’s been updated anyway.

lol it's still like this

Surely not?

[quote author=Nick Gammon link=topic=76494.msg1044410#msg1044410 date=1356466646] Surely not? [/quote]

Just checked it. Still doing whatever theyre doing w/ maint.