GPRS not working in GSM Shield

I bought the first generation GSM shield from Arduino in 2015 in India. Both GSM and GPRS worked very well. But, later I took the GSM shield to Europe. Now I assume it to work here as well.
B’cos the frequency in India and Europe are one and the Same. Now, in 2019, when I tried the GSM shield with all the updates SDK and with a local sim card, I was able to make calls successfully.

However, I am not able to connect to the web client.

I initially, thought my APN would be wrong. So I spoke to the customer support then they provided the correct APN settings. I verified with my phone and the sim works fine. When when I connect to the GPRS, it does not work. In the console terminal, it doesn’t say that the connection failed, its just blank.

Then, I decided to buy another sim card to try with another network. Then, it resulted in the same. Now, it don’t see any problem with my hardware. GSM works fine, but GPRS does not work.

I would like to know if someone had already faced this kind of issue before ? would you like to give my some clue in finding the actual problem?

The setup is simple :

  1. Arduino Uno ( I think this was R3 revision)
  2. Arduino GSM Shield ( Version 1)
  3. Connected to MACBookPro
  4. No additional wire connections or modification done like we do for MEGA or other board
  5. Arduino 1.8.3 SDK with GSM library(1.0.5) and trying to run the GSMwebClient with the following configuration
// PIN Number
#define PINNUMBER "3331"

// APN data
#define GPRS_APN       "internet" // replace your GPRS APN
#define GPRS_LOGIN     ""    // replace with your GPRS login - no login
#define GPRS_PASSWORD  "" // replace with your GPRS password - - no password