Having trouble with installing packages

When im installing an Package (kmod-video-uvc) for my Arduinoyun i get this error ´:

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-video-uvc:
  • kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) *
  • opkg_install_cmd: Cannot install package kmod-video-uvc.

can someone help

Max_Be:
When im installing an Package (kmod-video-uvc) for my Arduinoyun i get this error ´:

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-video-uvc:
  • kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) *
  • opkg_install_cmd: Cannot install package kmod-video-uvc.

can someone help

This is the 2nd time you have posted this.
I answered the first time that you need to use opkg manager to install packages.
The SD card does not have all the dependencies that are required.

Why are you not using the opkg manager?
Is the YUN connected to the internet?
If the YUN is not connected to the internet you are going to have a difficult time installing packages.

what errors does the opkg manager give you if you use it to install packages?

Is your YUN running OpenWRT or Linino?
I need to know that so I can test opkg using the correct YUN.
Please do not make multiple posts.

Max_Be:
When im installing an Package (kmod-video-uvc) for my Arduinoyun i get this error ´:

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-video-uvc:
  • kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) *
  • opkg_install_cmd: Cannot install package kmod-video-uvc.

can someone help

I have both an Arduino YUN running OpenWRT and an Arduino YUN running Linino.
when I issue the command "opkg list | grep -e ‘kmod-video-uvc’ " find any package by that name.
a search using duckduckgo.com does return one package.

On OpenWRT
root@posyun:~# opkg list | grep -e ‘kmod-v’
kmod-video-core - 3.3.8-1
root@posyun:~#

the same on Linino

https://wiki.openwrt.org/doc/howto/usb.video

kmod-video-uvc kmod-usb-core, kmod-video-core, kmod-input-core 35971
Kernel modules for supporting USB Video Class (UVC) devices. →Linux UVC driver and tools

Where did you get this package from?

Okay it occurred to me that both of Arduino YUN may have not been updated in a long time.
OPenWRT YUN
opkg update
updated the package cache.
kmod-video-uvc was now listed.

opkg install kmod-video-uvc returned

root@posyun:~# opkg install kmod-video-uvc
Installing kmod-video-uvc (3.3.8-1) to root...
Downloading http://downloads.arduino.cc/openwrtyun/1/packages/kmod-video-uvc_3.3.8-1_ar71xx.ipk.
Installing kmod-video-videobuf2 (3.3.8-1) to root...
Downloading http://downloads.arduino.cc/openwrtyun/1/packages/kmod-video-videobuf2_3.3.8-1_ar71xx.ipk.
Installing kmod-input-core (3.3.8-1) to root...
Downloading http://downloads.arduino.cc/openwrtyun/1/packages/kmod-input-core_3.3.8-1_ar71xx.ipk.
Configuring kmod-input-core.
Configuring kmod-video-videobuf2.
Configuring kmod-video-uvc.
root@posyun:~#

This Arduino YUN is using the ethernet connector and not WIFI.

I will try the Arduino YUN running linino later.

Okay I have been trying the Arduino YUN running Linino and I am getting the same errors that you have been receiving.

It appears that under Linino the package kmod-video-uvc depends on an older kernel than what is currently being run on the YUN. The older kernel package is not available for installation.

root@piyun:~# opkg install kmod-video-uvc
Installing kmod-video-uvc (3.3.8-1) to root...
Downloading http://download.linino.org/linino_distro/lininoIO/latest/packages/kmod-video-uvc_3.3.8-1_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-video-uvc:
 * 	kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * 	kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * 	kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * 
 * opkg_install_cmd: Cannot install package kmod-video-uvc.
root@piyun:~#
root@piyun:~# opkg info kmod-video-uvc
Package: kmod-video-uvc
Version: 3.3.8-1
Depends: kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a), kmod-usb-core, kmod-video-videobuf2, kmod-video-core, kmod-input-core
Provides:
Status: unknown hold not-installed
Section: kernel
Architecture: ar71xx
Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
MD5Sum: c27b270ee0810f480d9101ca8f455388
Size: 37932
Filename: kmod-video-uvc_3.3.8-1_ar71xx.ipk
Source: package/kernel
Description: Kernel modules for supporting USB Video Class (UVC) devices.
root@piyun:~# uname -a
Linux piyun 3.3.8 #1 Sun Oct 4 02:29:26 CEST 2015 mips GNU/Linux
root@piyun:~# opkg info kernel
Package: kernel
Version: 3.3.8-1-31b547152901f3179f11590e15e76a76
Depends: libc
Provides:
Status: install hold installed
Architecture: ar71xx
Installed-Time: 1443917989

I would not recommend mixing packages between OpenWRT and Linino.
I assume at this point that Linino is dead.
The last I had heard was that OpenWRT was being worked on to bring the YUN up to date.

Between the Arduino Yun OpenWRT and the Arduino Yun Linino there are physical differences.
That there are physical differences would keep me from trying to load OPenWRT onto the Yun currently running Linino.

Not sure where that leaves you.

You cannot just compile from source, because you would be a cross-compiler.
You would have to build on an X64 and raspberry-pi.
Raspberry Pi would probably be easier but definitely slower.
You may find that the dependencies would prevent even compiling from code.

Find someone with an Arduino Yun running OpenWRT and swap boards with them.

I have to do some more digging around.

I will let you know what I find.

Max_Be:
When im installing an Package (kmod-video-uvc) for my Arduinoyun i get this error ´:

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-video-uvc:
  • kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) * kernel (= 3.3.8-1-04487771b2235794a056b9dddb5c434a) *
  • opkg_install_cmd: Cannot install package kmod-video-uvc.

can someone help

Hello

Have you found a solution for this?

No solution yet...
I will try to get a new yun with openWRT
Thx for replying