How to change Arduino IDE menu font size?

Hi all, how can I change the Arduino IDE menu font size? Reason: I have installed a lot of cores and my screen is not large enough to show them all. The respective menu does not scroll down, so I’d like to choose a smaller font for the menus. I did find settings to change just about every other font but not the menu font. I am using Ubuntu.

did you look into File menu -> preferences -> preferences.txt

editor.font=Monospaced,plain,12

Be aware you must change this file without any IDE running, as the IDE saves the settings upon close

and backup the file before changing !

add/check also these ... build.verbose=true upload.verbose=true

Thanks, but editor.font does not affect the menus... the menus are "somehow" coupled to the system font. While this may work on many OSes, the result is a too large font (at least for my taste) in Ubuntu where it fails to match the real system font...

probono: Thanks, but editor.font does not affect the menus... the menus are "somehow" coupled to the system font. While this may work on many OSes, the result is a too large font (at least for my taste) in Ubuntu where it fails to match the real system font...

Come to Windows, we have cookies and scrollable menus ]:D

I’d like to know this too. For some reason, my Arduino IDE (1.0.3, downloaded from the website just now) starts up with menu and UI (e.g. preferences window fonts) so small that I can’t read them – see attached.

I’m running kubuntu quantal, with OpenJDK Runtime Environment (IcedTea7 2.3.3) (7u9-2.3.3-0ubuntu1~12.10.1).

Edit: I’ve also tried IcedTea6 and Oracle Java 7. Same thing.

Nevermind. Fixed after reboot.

haHAHAHA! at least was a funny glitch

On Linux, I was able to solve this by creating a file called "fontsettings" with the following content:

style "small" {
        font_name = "Sans Condensed 8"
}
class "GtkWidget" style "small"

Now I have to

export GTK2_RC_FILES=$GTK2_RC_FILES:./fontsettings

and then launch Arduino. Of course you can integrate the export statement into the Arduino launch script.

I'm running a Debian-based Linux and had the same problem with impossibly small menu text when using the Arduino IDE version 1.0.5

The solution for me was to edit the arduino script (/usr/bin/arduino on my system) to get rid of the GTKLookAndFeel.

From this:

java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"

To this:

#java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"
java processing.app.Base "$@"

Thanks,

This worked beautifully,

did you look into File menu -> preferences -> preferences.txt

I was having a hard time seeing the sketch font, this fixed my problem.

Thanks...........Antonio

16kRAM: I'm running a Debian-based Linux and had the same problem with impossibly small menu text when using the Arduino IDE version 1.0.5

The solution for me was to edit the arduino script (/usr/bin/arduino on my system) to get rid of the GTKLookAndFeel.

From this:

java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"

To this:

#java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"
java processing.app.Base "$@"

This one is on the money on Puppy Linux also -Thanks heaps . My eyes were nearly gone and I avoided using Arduino cause I could not see it .

The "#" comments out the line so the line is replaced with java processing.app.Base "$@"

I started another thread on this Yesterday so I will reference that to here also

Now if I can just work out how to get it a bit bigger again

Also noticed in Puppy Linux and maybe others the font choice in preferences is wrong. Look for the line that says Monospaced,normal,12 and change to Monospace,bold,20 for a bigger bolder show for tired eyes. Could probably use other fonts here too

This probably applies to Ubuntu also.

The arduino ide had weird unusable fonts in knoppix usb distro. It is pretty stripped down and I figured it was subbing a font as best it could but to no avail. I tried

sudo apt-get install msttcorefonts

and it was perfect afterwards.

sudo apt-get install msttcorefonts

I gave the above a try but it did not change anything for me on Puppy linux but maybe I need to do something else on the installation .

Definately

java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"

java processing.app.Base "$@"

works .

I am having difficulty reading my arduino text code on screen in the arduino ide, it appears not be be a true black. When I copy it to notepad++ and try to print it on paper, it prints very light. I have used the notepad++ setting to make text darker which helps, but it is a long way around. Is there a way to get the arduino ide to just display true black letters?

Thanks jwmcnc

16kRAM: I'm running a Debian-based Linux and had the same problem with impossibly small menu text when using the Arduino IDE version 1.0.5

The solution for me was to edit the arduino script (/usr/bin/arduino on my system) to get rid of the GTKLookAndFeel.

From this:

java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"

To this:

#java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"
java processing.app.Base "$@"

thank you, it's work! problems in bad GTK+ LookAndFeel theme, we can chenge LAF theme for example to Numbus:

JAVA_OPTIONS=("-DAPP_DIR=$APPDIR" "-Dswing.defaultlaf=com.sun.java.swing.plaf.nimbus.NimbusLookAndFeel")

or Motif. Mmm... Cutie...

JAVA_OPTIONS=("-DAPP_DIR=$APPDIR" "-Dswing.defaultlaf=com.sun.java.swing.plaf.motif.MotifLookAndFeel")

or remove LAF parameter:

JAVA_OPTIONS=("-DAPP_DIR=$APPDIR")

JAVA_OPTIONS=("-DAPP_DIR=$APPDIR")

This change worked for me. (Linux Manjaro 17.1 with KDE Plasma5)