How to use Arduino IDE 2.0.0.B9 in offline mode?

Hello,
I try to walk my first steps in Arduino and purchased a Nano PR2040. I downloaded the IDE 2.0.0-B9 but it looks like there is now reasonable way to run it offline. I found a old threat about this problem for a older version of an IDE. It was mentioned that creating a folder called "portable" will force the Module Manager to store all downloaded files into this folder instead of the typical User - folders. I tried to install the IDE on a laptop with internet access, loaded uncompressed the zip download file and started the board manager, but he ignored this folder and used the user folders.
The idea was to download all packages I need on a different laptop, copy the portable folder or the whole IDE- Program folder to the final targed pc.
Actually this way do not work beause the Manager use the user folders and this is too much work, to copy all related sub folders. Additonally I do not know what is going on with the registry.
Are there any recommendations how I can use the IDE 2.0.0-B9 and the final version later on in a offline mode?

Thanks in Advance Tom1000

Hi @tom10001. Thanks for giving the beta stage Arduino IDE 2.x a try!

As you discovered, it does not currently support the same portable system as the classic Arduino IDE. That deficiency is being tracked here:

It does offer quite a bit of control over the location of the folders it uses, which can be configured in the Arduino CLI configuration file. The locations of that file are:

  • Windows: C:\Users\<user name>\.arduinoIDE\arduino-cli.yaml
  • Linux: /home/<user name>/.arduinoIDE/arduino-cli.yaml (AKA ~/.arduinoIDE/arduino-cli.yaml)
  • macOS: /Users/<user name>/.arduinoIDE/arduino-cli.yaml

Documentation of the available configuration options:
https://arduino.github.io/arduino-cli/latest/configuration/#configuration-keys

You should be able to get by with copying a single folder:

  • Windows: C:\Users\<user name>\AppData\Local\Arduino15
  • Linux: /home/<user name>/.arduino15 (a.k.a. ~/.arduino15)
  • macOS: /Users/<user name>/Library/Arduino15

Thanks for your pretty fast answer. I will follow the steps described there. As soon as possible i will give a feed back.

best regards Tom1000

Hello Pert,
I tried to follow your recommendations.

Let me tell you what I've done finally.

  1. Installed the IDE 2 on the tarted pc without internet access
  2. patched the arduino-cli.yaml file in order to fit the different paths inside the "directories:" structure to my setup.
    -> The IDE starts but stuck because of no internet access. There are two error messages diplayed. (Requested loadSketch faild with messages: 2 UNKNOWN downloading bulitin.ctags@..... // 2nd Message: There was an error creating the sketch directory...)

-> The first message is clear, he cannot load the ctags-5.8-arduino11-rpn... package because of the offline situation.
-> the second one is not really clear but could be a result from the first error, I don't know.

  1. Installing IDE2 on a win10 system with internet access

  2. Starting the manager, and loaded all modules I assume are importand for the RP2040.

  3. Moved all data from Arduino15 folder of the pc with internet access to the pc without internet access

  4. Start the IDE2 on the pc without internet access.
    -> The IDE opens about 11 tasks in the task manager but is doing nothing, just the waiting symbole is turning the blue dots...

Actually there is no way to start the IDE on a pc without internet access.
-> NOT GOOD !!!!

Have you some more recommendations how I can run the IDE2 in my offline PC?

Gretings
Tom1000

It's true that an Internet connection is required to download this tool. However, once it has been installed, the IDE should happily start up with no Internet connection. I expected that this tool would have been manually installed by you to your offline PC when you copied the entire data directory over from your Internet connected installation.

I just gave it a try and had no problems. Please check your data directory ( C:\Users\<user name>\AppData\Local\Arduino15 by default, but you might have customized it via arduino-cli.yaml) to see if the file exists at packages\builtin\tools\ctags\5.8-arduino11\ctags.exe.

That is correct.