I keep getting this odd message whenever I try to upload to my Arduino Mega 2560

I just ordered an Arduino Mega 2560, and so far, I've managed to upload programs to it successfully. However, whenever I tried using any of the extra digital pins that it comes with, they wouldn't work. I just tried using them again—specifically, here is the code I wrote before the void setup() part of my program:

int cathode01 = 22;
int cathode02 = 23;
int cathode03 = 24;
int cathode04 = 25;
int cathode05 = 26;

Then, when I tried uploading the program, I kept getting a message that said "avrdude: stk500_2_ReceiveMessage(): timeout." Now whenever I try uploading anything at all to the Mega, I receive the exact same message. I've tried holding down the reset button before uploading programs, I've tried removing the Mega from "Networks" under "System Preferences," I've tried checking the board and the serial port…but to no avail. Please help? Thanks.

However, whenever I tried using any of the extra digital pins that it comes with, they wouldn't work.

There is nothing wrong with that code, such as it is. However it is trivial and tell us nothing.

Read the sticky post and go through the procedures, but it looks like you might have blown up your arduino through some electrical abuse or other.

The oddest thing just happened. I just disconnected everything from my Arduino, quit Arduino on my computer, then reconnected the Arduino to my computer—without any electronics connected to the Arduino. I tried uploading the program I had been working on last night, and this time it uploaded fine. I haven't changed or done anything. I didn't even run the test. o_O

Now it appears as though pins 24-53 are perpetually low, and pins 22 and 23 are perpetually high. Odd.

So what you wired up to these pins?

I tried connecting an LED to various pins and uploading the Blink program. It worked fine for pins 13 and 8, but when I tried pins 22, 23, and 24, it didn't work. 22 and 23 were always high, no matter what, and 24 was always low.

Do you think there is a chance I shorted that part of the board somehow?

The LEDs had resistors on them? What value?