I want to use E34-2D4G20D module.I don”t know what library for this module to use?

I want to know solution.

Perhaps provide us with a link to the device and we may be able to help.

When I add a library for E34-2G4D20D module, Arduino IDE show that " Specified folder/zip file do not contain a valid library "

What exactly have you added and how did you add it ?

What does the folder structure look like after your library installation and which files are in the folders ?

Topics merged

The title of the post asks for information on a 'E34-2D4G20D' not E34-2G4D20D module .....

Ok sir.Do you know this solution?

Pls download pcb liberary for E34-2G4D20D here.

http://www.ebyte.com/pdf-down.aspx?id=665

I use this library but when I downloaded and added zip file,I saw java codes.I no understand that codes.When you add this zip,you will see java code error.Please give me solution after you added this zip in your Arduino IDE.

Pls download pcb liberary for E34-2G4D20D here.

http://www.ebyte.com/pdf-down.aspx?id=665

You see java code error after you added this zip in your Arduino IDE.Pleas help me sir.

https://www.tkolbehvila.com/index.php?main_page=product_info&products_id=201636

I use this module in link.I need library for this module in above link

When I add a library for E34-2G4D20D module, Arduino IDE show that " Specified folder/zip file do not contain a valid library "

@thetpaingphyoe

Stop opening multiple topics on the same subject or you risk being suspended for a period of time

The latest one in the Libraries section of the forum has been deleted

1 Like

Hi pro!!

I need a zip file(library) for E34-2G4D20D module.

I can not search in google.

So I need helping to get a zip file for this module.

Please help me

Sir!!!

You made a post recently saying you had such a library;

And can you provide a link to the module your using ?

No sir.Although Ebyte company gave me a library for this,I am no okay to add this library because
Arduino IDE show me error that java codes.

So I an finding suitable library for this module.
Can you can help me!
pls sir!!


this is error codes.
When I added library for E34-2G4D20D module,I faced as you see below

Exception in thread "AWT-EventQueue-0" java.lang.IllegalArgumentException: MALFORMED
at java.util.zip.ZipCoder.toString(ZipCoder.java:58)
at java.util.zip.ZipFile.getZipEntry(ZipFile.java:566)
at java.util.zip.ZipFile.access$900(ZipFile.java:60)
at java.util.zip.ZipFile$ZipEntryIterator.next(ZipFile.java:524)
at java.util.zip.ZipFile$ZipEntryIterator.nextElement(ZipFile.java:499)
at java.util.zip.ZipFile$ZipEntryIterator.nextElement(ZipFile.java:480)
at processing.app.tools.ZipDeflater.deflate(ZipDeflater.java:41)
at processing.app.Base.handleAddLibrary(Base.java:2245)
at processing.app.Base$6.actionPerformed(Base.java:1069)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
at java.awt.Component.processMouseEvent(Component.java:6533)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
at java.awt.Component.processEvent(Component.java:6298)
at java.awt.Container.processEvent(Container.java:2236)
at java.awt.Component.dispatchEventImpl(Component.java:4889)
at java.awt.Container.dispatchEventImpl(Container.java:2294)
at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
at java.awt.Container.dispatchEventImpl(Container.java:2280)
at java.awt.Window.dispatchEventImpl(Window.java:2746)
at java.awt.Component.dispatchEvent(Component.java:4711)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
at java.awt.EventQueue$4.run(EventQueue.java:731)
at java.awt.EventQueue$4.run(EventQueue.java:729)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

I know solution.

Why not just copy and paste the error? I mean how easy is it to read that terrible image?

Why not post the solution if you know it?

Invalid library is your error, use a valid library is the solution.

Yes I know valid library but cannot search a valid library in google

This will not be very productive. Not posting the entire error message and making double postings.

Why duplicate postings?

https://forum.arduino.cc/t/i-face-to-this-problem/906406