IDE 1.6.12 won't start up

I installed 1.6.12 on my Windows 7 computer and it refuses to start. This is what I get when I run Arduino_debug:

|500x254

Anyone have any ideas?

You could try deleting(or rename to back it up if you want to save your preferences settings) the C:\Users\generaltest\AppData\Local\Arduino15 folder, then try starting the Arduino IDE again. If that doesn't work I have another idea you can try.

Thanks for the suggestion. I looked for the folder Arduino15 but it doesn't exist. Hidden files & folders is turned on.

OK, plan B, use Arduino IDE in portable mode by creating the folder c:\Program Files (x86)\Arduino\portable then try to start the Arduino IDE again.

I created the folder and started the IDE. It almost immediately quit. I checked the debug and the error is the same. I did see sketchbook and preferences.txt in the portable folder though.

You could try running the Arduino IDE as administrator.

Running as admin did not change the situation.

I did resolve the issue though. The computer that this was happening on was in a domain. There was a roaming profile set and I believe someone deleted some Arduino files when they updated from one version of IDE to a newer one.

When running the debug it was referencing something in the Local profile. I set the Active Directory user to use local profiles, logged on to the computer as an admin and removed the affected local profile. I also uninstalled IDE. With the local profile gone I logged in as the affected user, confirmed a new local profile was created and installed the new version of IDE. It finally opened. I set the AD user back to the roaming profile, logged in as the affected user and the IDE still worked.

What an awful problem.

try to use non-admin version of Arduino.

https://www.arduino.cc/download_handler.php?f=/arduino-1.6.13-windows.zip

@ KoolArduino

There are two options for “running as administrator”

The first one is essentially an elevated user administrator. (per case use)

The second is FULL Administrator. (Enable administrator at logon)

Which one did you use ? (2nd preferably)
Whilst still in the mode set the permissions for the Arduino software for the other users too.

Network / domain based installs can be a PITA for some software and the IDE is no exception in that regard.