IDE 1.8.8 Keeps crashing on Load

Can anyone help me figure out what I need or what might be the problem

After I download the IDE 1.8.8 for Mac OS X (10.8 ) it downloads ok, and when I click on it it just opens, no prompt to install. (just asks if trusted) and when I clock on it to open it, it loads (what I assume is normally) but when finished, it will only open for maybe a second, long enough for me to see the interface, and then crashes.

its an older laptop, but should be more then enough to run the software.

Im running OS X 10.11.6 on a macbook pro.

am I missing a driver or is there something Im missing about download the IDE software?

Thank you

There is a bug in Arduino IDE 1.8.8 that causes it to be incompatible with any macOS version older than 10.12: https://github.com/arduino/Arduino/issues/8274

This bug has already been fixed, but there has not been an IDE release since then. Please use Arduino IDE 1.8.7 until the next IDE release comes out. You can download Arduino IDE 1.8.7 for free here: https://www.arduino.cc/en/Main/OldSoftwareReleases#previous

pert: There is a bug in Arduino IDE 1.8.8 that causes it to be incompatible with any macOS version older than 10.12: https://github.com/arduino/Arduino/issues/8274

This bug has already been fixed, but there has not been an IDE release since then. Please use Arduino IDE 1.8.7 until the next IDE release comes out. You can download Arduino IDE 1.8.7 for free here: https://www.arduino.cc/en/Main/OldSoftwareReleases#previous

Thank you. I will give that try.

Thank you again for your help.

You're welcome. I'm glad if I was able to be of assistance. Enjoy! Per