IDE 2.0 beta 4 Ubuntu 21.04 first time install

I just got a new computer so installed Ubuntu 21.04 - I thought I would try the new Arduino IDE 2.0… So far it is almost unusable… Some Notes…

  1. difficult to invoke - the IDE downloads as an appImage file but with no extension…
    Ubuntu is getting more and more like Windows - it pays some attention to file extensions… If you double double-click on arduino-ide from the file manager Ubuntu does not know how to open it… Changing the name to arduino-ide.appimage solves this problem… **** A suggestion for the Linux version ***
    … but you still can’t add the IDE to the favourites in the dock…

I did have this IDE working yesterday - I seem to have made the mistake of loading a sketch from my other computer via a samba share… Now today the IDE just hangs up looking for the previous sketch or library or something… Totally unusable… I looked around for preferences.txt but only found some .json files in ~/.arduinoIDE - I removed reference to the samba share is several files but my IDE is dead… just a spinning circle…

Well - it was OK while it lasted - with the major problem of it wanting more screen than I have - it ran off of the bottom on my screen - 768 vertical resolution…

I’ll have to do a reload and see how for I get - maybe next month when hopefully things may have been improved…

1 Like

Hi @arduinoshop. Thanks so much for your valuable feedback about the beta Arduino IDE 2.x!

I have also run into this and have seen multiple reports about it:

Thanks for sharing a suggested fix. I have now added it to the issue tracker where the development team is tracking this. Hopefully it will be resolved in an upcoming release.

I wonder if it’s related to this?

Some improved error reporting has been added since the Arduino IDE 2.0.0-beta.4 release. Would you mind trying the nightly build of the Arduino IDE 2.x to see if it will provide you with an error message in the notification area at the bottom right corner of the IDE window? You can download the nightly here:

If you get that error message, please post the full text here and I’ll investigate. If there is nothing, then I can suggest some other troubleshooting techniques.

preferences.txt is no longer used.

There is also a file named arduino-cli.yaml that is very important and contains some path configurations. You can get information about that file here:
https://arduino.github.io/arduino-cli/latest/configuration/#configuration-keys

I also had this problem on my supplemental laptop. Fortunately, this bug has been fixed since the last release:

You’ll get access to that fix by using the nightly build.

This is a beta phase piece of software that is under very active development, so you’ll definitely be seeing significant improvements as time goes on.

I installed the nightly build… the IDE no longer falls off the end of my screen - I love the dark theme… I was able to compile a large sketch from a samba share on my other computer… all went well - picked up the libraries etc…

Until I went to upload - timeouts - I must have had the port tight because the Serial Monitor was seeing the output from my board… I closed the IDE… when I reopened it most every thing went blank… many with tomorrow night’s update I will have better luck…

Defineitly a problem with lack of meaningful error messages…

Also I see no option to select a programmer - I ofter use a USBasp…

keep up the good work…

I’m sorry to hear that. It will be difficult to do an investigation without more information about your problem.

In Arduino IDE 2.x, as with Arduino IDE 1.8.13 (but not earlier IDE versions), the Tools > Programmer menu is dependent on the Tools > Board (or the new board dropdown menu) selection. Only the programmers that can be used for the currently selected board are shown.

So if you select one of the boards from Tools > Board > Arduino AVR Boards menu, you will then see a Tools > Programmer > USBasp, but if you don’t have any board selected, or you have a board selected from a platform (e.g., Tools > Board > Arduino SAMD (32-bits ARM Cortex-M0+) Boards) that doesn’t have USBasp support, then you will not see that programmer option.

Thanks for the quick reply… In the interest of being fair I simplified my installation with an mega2560 connected directly rather than using a USB expander and brought my “big” sketch over to the disk on the same computer to avoid concerns over the “Samba” share… I deleted .arduino15 and .arduinoIDE and download the Apr14 nightly…

I opened the Blink example and was able to compile and upload successfully… very fast… or maybe that was the reason I bought the new computer…

I did notice that the programmer selection did show up as advertised…

So for this moment only suggestion is a “launcher” for Linux/Ubuntu

I am going to try my “big” sketch and see what happens…

Thanks for the update. I’m glad to hear you’re having success so far.

There have been some improvements in compilation speed in Arduino CLI, and Arduino IDE 2.x inherited those improvements due to using Arduino CLI to run the compilations. I have also noticed some significant improvement in this respect.

It actually may be even faster than it appears if you have verbose output enabled. There is currently a bug where some bottleneck is causing the console output to be slowed down. So you’ll notice that the actual compilation and upload finishes long before the output finishes scrolling through on the console.

so I tried my “big” sketch and got it to compile and upload…

Suggestion… us Arduino users are used to the IDE remembering the board and port settings from one invocation to the other… I had to learn the hard way what

Compilation error: Error: 2 UNKNOWN: no FQBN provided means

I’m guessing FQBN means “Fully Qualified Board Name”… naughty, naughty…
many Arduino users are newbies… and may not be able to guess this…

Only other comment is I did not see a way to install a library from a ZIP file…
maybe also the ability to reduce/remove the height of the Output window… with my eyesight problems I have to use a 32" monitor set to 1360x768 resolution which leaves very little “extra” vertical space…

Now I’ll try to see if I can break it again using Sketches from the network…

I was easily able to break it when Itried to use a Sketches folder on the network

If I use the preferences dialog to select my sketches folder the cli file gets:
user: /run/user/1000/gvfs/smb-share:server=art-inspiron-530.local,share=arduino
… this breaks the IDE completely…

If I change the cli to:
user: smb://art-inspiron-530.local/arduino/
the IDE staggers up but looks like it blows the parsing of the cli file
when I examine the sketches folder from the preferences dialog I see a “/” in front of the “smb://…” it also does not pick up the theme setting( which is my big attraction to IDE 2.0… previous releases of 1.8.xx varied wildly in how themes were handled - they are 3rd party - only 1.8.10 was satisfactory )

tomorrow I’m going to try a non-arduino board ESP-32 and LGT8F328p

Don’t know if it is just my new computer but 2.0 is lightning fast… GREAT!!!

This is a known bug that is being tracked here:

This is a known bug that is being tracked here:

It should be at Sketch > Include Library > Add .ZIP Library… just like in the classic Arduino IDE. Do you not see it there?

There are two ways to hide the output window:

  • Right click the tab, then select “Collapse”
  • Click the bottom panel control icon at the bottom right of the Arduino IDE window.

To determine which application is the culprit, please do an experiment using Arduino CLI directly. Even though there is a copy of Arduino CLI installed along with Arduino IDE 2.x, it will probably be easier if you install a separate copy of Arduino CLI. The nightly builds (which are the appropriate ones for beta testing) are available for download here:
https://arduino.github.io/arduino-cli/latest/installation/#nightly-builds

You will need to make sure Arduino CLI recognizes your custom arduino-cli.yaml file (it won’t use ~/.arduinoIDE/arduino-cli.yamlby default. Info on that here:
https://arduino.github.io/arduino-cli/latest/configuration/#locations

Yes, the classic Arduino IDE’s themes are not supported by Arduino IDE 2.x. It uses VS Code themes, so this opens up the possibility of a huge number of theme options.
https://github.com/arduino/arduino-ide/issues/139
There is no tutorial I’m aware of on how to add custom themes to Arduino IDE 2.x currently, though probably there are some non-Arduino-specific tutorials that would apply. You can see an example here:

Great! I’ve used both with Arduino IDE 2.x and had no problems.

1 Like

no time to try the other MCUs yet…
but I did get a "launcher’ up
The classic IDE installation copies a “.desktop” file into the ~/Desktop directory
o after renaming the arduino-ide file to arduino-ide.appimage
then modifying the Exec= line in the .deskop file to reflect the full path to the
arduino-ide.appimage file you should see some evidenc of it on your Gnome desktop…
You can right click on this and change permission to allow execution…
another right-click should give you the option to allow launching
in my case because I was modifying the .desktop file produced by the classic IDE
the desktop icon changed to the Arduino icon.
You can now double click on the icon and the IDE opens and a generic icon shows in the favourites… but right clicking on this icon does not give the option to add to favorites… this is a Ubuntu/Gnome thing - something about making the ,destop ( or maybe the appimage file “trusted” which I have not yet figured out…

all of this worked for me on a fresh install of Ubuntu 21.04

just 1 other comment/correction…
In the preferences dialog when you want to select a Sketches folder the button to do the select is labelled “Chose”… should be “Choose” ( present tense )… picky-picky me…

But I seem to have a working IDE - and fast

Hope that these comments may help Ubuntu users…

1 Like

I’m definitely interested in this subject and am passing on the information you’ve shared to the IDE team, so please let me know if you make any further progress on that.

Nice! We are kindred spirits in this respect. I went ahead and submitted a pull request to fix this error:

Finally got it… here is the .desktop file

=============================================
[Desktop Entry]
Type=Application
Name=Arduino IDE 2.0
GenericName=Arduino IDE
Comment=Open-source electronics prototyping platform
Exec=/home/art/Downloads/arduino-ide_nightly-20210416_Linux_64bit/arduino-ide2
Icon=arduino-arduinoide
Terminal=false
Categories=Development;IDE;Electronics;
MimeType=text/x-arduino;
Keywords=embedded electronics;electronics;avr;microcontroller;
StartupWMClass=arduino ide
====================================================

as you can see I renamed the appimage to arduino-ide2 to avoid conflict with the classic IDE ( maybe not necessary )

make this .desktop file executable and copy it into /usr/share/applications

( if you copy it into ~/Desktop it will show on the desktop… )

then when you hit the “super” key and search for “ard” it’s icon should show up
right-click on this icon and you should see “Add to Favourites”
la voila…

notice that the icon is from the classic installation…

1 Like

In retrospect the best suggestion would be to include an “install.sh” with the Linux package as the classic IDE does… I think it does all of the things I have mentioned… would just need a couple of tweaks… Do you have Icons for the 2.0??

There is definitely a problem with the icons situation on Linux right now. It’s just pure black:

The fix has been accepted by the Arduino IDE developers and will be in the next nightly build and all releases after that. Thanks again arduinoshop!

Thanks - just downloaded 0430 nightly - FIXED…

Hi @arduinoshop. The team in charge of the development of the Arduino IDE have decided that the time has come to resolve this issue. I’ve shared this thread with them.

Would you like to submit a pull request to the arduino/arduino-ide repository directly so you can get full credit for this important improvement? I’ll be happy to participate in the testing and review process.

I would be honoured and delighted to participate…

I will try to do the pull request…

1 Like

I am rather new at using github… I think there would have to be an issue open to do a pull request… The only one that looks close is for Arduino IDE Pro - should I “pull” on that issue?

I’m happy to help out. Please let me know if you have any other questions.

Although the maintainers of some projects do require this, we don’t. There are benefits to it, but it also adds extra work for the contributors.

But in this case, there is an issue here: How to get started · Issue #110 · arduino/arduino-ide · GitHub
It drifted off topic to the subject of problems caused by using certain extraction utilities in the comment thread, but the original post was about someone trying to start the application from Files and getting that confusing error:

There is no application installed for “shared library” files