IDE Download failed

Hey everyone,

I am new to Arduino and just got my first UNO in the mail today! I am very excited to begin however whenever I try to download the IDE I receive a "failed" message. This includes both the .exe and the .zip folder. I am using FireFox on a Windows Surface Pro 3 running Windows 8.1.

Can anyone help please!?

I attached a PNG of what I am getting. I get no error message, just “failed”.

Unsure why, but after 15+ more failed attempts, the .exe installer finally worked. Unsure if the issue was on my end or with Arduino's servers.

Solved but not understood. :)

Another recent new member was seeing the same, looks like there was some downtime on the Arduino end.

Better than what I saw this morning - went to check my bank balances on line, all account showed balances of **** . Luckily part of the system was just offline (I called). Had me a little nervous tho 0)

Also Arduino newbie. Getting 503 on the download link for the linux 64 bit archive.

Is the server down? Getting 503...Sitting here with electronics everywhere, ready to go!

same here, 503 across the board

There appear to be server issues at the moment. Try again later.

Help! I'm new to Arduino, too but when I input the following address,

www.arduino.cc/en/Main/Software

I got what the above members got, a "failed" message.

Help!!!

Loeezy :confused: :confused: :confused: