Install problems on Win XP

I'm trying to get started with an Arduino Diecimila on a Windows XP system.

Downloaded The USB and serial drivers installed without a problem. Starting either run.bat or arduino.exe seems to work ok, except that there is an immediate message:

"avr-g++: _spawnvp: No such file or directory"

Something is not linking correctly. Tried putting the arduino-0010 directory in various place with no change in behavior. Cleaned the registry and preferences.txt when moving. Tried The message is slightly more verbose for 0009:

"avr-g++: installation problem, cannot exec 'cc1plus': No such file or directory"

cc1plus.exe is there (...\avr\libexec\gcc\avr...) but the program cannot find it.

Trying to compile blink, get errors confirming that the compiler is not found:

"Couldn't determine program size: ..."

Communication with the Diecimila board actually appears to work, but I have nothing to upload because I cannot compile.

The troubleshooting guide talks about conflicts with other cygwin1.dll on my computer. That is probably related to what is going wrong. However, eliminating the other cygwin1.dll does not fix anything. Perhaps I am missing something very simple. Any hints about what to try next?

Do you get the same error if you open a command prompt, cd to the Arduino directory, and run hardware\tools\avr\bin\avr-gcc? What about avr-g++?

The same error happens from the command line going directly to avr-gcc or avr-g++ (avr-g++: _spawnvp: ...).

I couldn't find any reference to the problem in this user group. Using Google, I found a similar problem in another AVR group:

I have no doubt that the problem will go away if I completely clear away all other Cygwin related tools from my machine. Unfortunately, that is not an option. I've run out of time today to do more experiments. I will try some things over the next day or two and report back on what corrects the problem.

Hmm, you don’t have any other versions of avr-gcc or avr-g++ installed do you? What if you add the directory containing cc1plus to your path? What directory is Arduino in? You might trying moving it to the root directory, e.g. c:\arduino. Are you running as an Administrator? If not, you might try that, too. Sorry I can’t offer more specific advice.