Installed Sloeber Arduino IDE - need some startup instructions

I don't know if this is a proper place to put questions about the Eclipse Sloeber Arduino IDE, but I will try anyway...
I have just started using Arduino in order to make a special WiFi application using an ESP-07S module with ESP8266.
But I had great problems working with the Arduino IDE and when I asked about these I got a recommendation to use Eclipse instead, specifically the Sloeber Eclipse IDE plugin (installed from the "product" which says it includes Eclipse, Java and all else you need)...
So I downloaded the installer (64bit) to my Windows7 X64 PC and ran the installer, then started the program.
Now I have come as far as reaching the IDE and via the "File/Open Projects from file system" menu I navigated to the already started sketch directory ehere the ino file resided and it opens in the new IDE.
I can get edit windows for the files involved (which I could not in the Arduino IDE).
But, nothing happens if I use the Verify command in the toolbar (except for opening an empty messages box at the bottom of the right-hand pane. THere seems to be no compile or anything like that performed.
So I suspect I have not installed it properly.
What are the steps to take in the IDE before opening an existing project (sketch)?
Seems likely I have missed something important.
One observation:
When I first opened the IDE there was a window saying it was installing stuff and then suddenly Windows Firewall popped up a message about it having blocked access to the Internet from this program:
C:\Programs\sloeber\sloeber-ide.exe
It took a little while before I realized I had to click a button to allow access, but at that time the "installation window" had disappeared. Maybe it could not complete and my installation is now incomplete or something?
How can I manually repeat whatever was going on at first start, if that is what it takes?

And is there some working tutorial on how to actually go from the downloaded installer to a position where one can start working on an existing ESP8266 based sketch without problems?
I have found this: Sloeber - getting started
but it is very strangely done and I cannot find a "guide for dummies", which I probably need.

I attach a screenshot of my project properties page, what should I do here to make the IDE understand that it should be compiled with Arduino?
I have even entered a bogus call to a non-existing function in the ino file, but Verify does not result in anything anyway…

your project is not a Sloeber project.

first install the esp8266 package in Window|Preferences|Arduino|Boards. version 2.4.1 is new.

then create a new project of type “Arduino sketch” and copy the source files into the new project

Screenshot from 2018-03-12 07-37-18.png

  1. I had imported the esp8266 board but chose version 2.0.0
  2. Even so the Arduino item in the project properties did not show up...
  3. But now I have followed your advice in my other thread to create a new Arduino Sketch project and then it does activate the functionality I was looking for.

However, I realize I should switch to esp8266 version 2.41 and here I ran into problems following your instruction above...
When I change the "Platform folder" from 2.0.0 to 2.4.1 then the data that were filled in below disappeared and I cannot enable the Apply button unless I fill in all the boxes above. And I have no idea what all of them should be set to.
The box does not look like your screenshot at all, it has a lot of stuff to be filled in and I don't know all...
The board is set to "Generic ESP8266 Module"
Is there no library of boards one can download so I can just select the ESP-07 board and get all of the correct settings?
Here is my properties page (is there no way to upload an image to the forum rather than to an external website as I had to do now?):

sorry my screenshot is for AVR.

with 2.4.1 you get the same options in Arduino IDE.

common options
Capture.JPG

some of the options are for the module or board you have and some options are your choice.

board/module dependent: crystal frequency, flash frequency, flash mode, flash size, led, reset

your choice: CPU frequency (power consumption and heat), debug, Erase flash, lwip, upload speed

Thank you Juraj! Helpful as always! :slight_smile:
I asked in my other thread (about viewing header files) if there is a way to add existing files to the project.
But apparently it annoyed someone so I will ask in this thread instead:
How can one add existing files to the project if they are already copied into the project folder but not recognized by the project itself. In other IDE's there is often a project level "Add Files" command/button which opens a browser where one can point to existing files and add them to the project list.
Is something like this available here? I have yet to find it....
The only thing I found was the top left button (file icon with a + in the upper right corner) where one could creae a new file but it overwrote the file I had copied in....

I copy paste or drag files to tree in Eclipse. if you added them outside Eclipse, use Refresh in pop-up menu or F5 on tree node in Eclipse

@Juraj
Thank you for pointing me to Sloeber IDE for Arduino! It has upped my productivity a lot! :slight_smile:

Now after a couple of days worth of coding in a new project I created inside Sloeber IDE but moved code to from my old Arduino IDE sketch, I have a big chunk of code that verifies without errors or warnings.
So it needs to be stuffed into Subversion...

Do you know which files should be ignored in a typical project, but are located inside the project folder?
I have to adjust my ignore settings in svn before I import the project.
Files that get rewritten every time and intermediates etc should be ignored, but which are they?

I use Git. I add to version control only my source files. The project configuration files are .project and .cproject. All other files are temporary.

I imported my project to Svn using the “–depth files” argument in order only to get the source files and the configuration files you mentioned. Then I renamed the project dir as .bak and checked out from svn into a folder by the same name as before.
When I now started the Sloeber IDE it did not open the project as I expected, instead it showed messages as “out of sync something” and “please press F5 to refresh”.
After I had done so a number of times my files display as before, except now they are showing loads of identifier not found errors…
As an example all of these includes are “unresolved reference”:

#include "Arduino.h"
#include <ESP8266WiFi.h>
#include <FS.h>
#include <EEPROM.h>

There must have been some important file(s) I should have also added to svn…
And in the project explorer it says to the right of the project node “no Board:no port”
Where is this information stored? It should have been included with the project in svn…

After having taversed the project properties page and set the values according to memory I have gotten rid of the errors and it builds.
But the resulting bin file is very different from the one created by the original, so this indicates that one really would need to version also the projects settings regarding the stuff set on the properties page.
Where is this stored?
In the .settings directory maybe?

.settings/org.eclipse.cdt.core.prefs

Progress update:
I moved away the non-versioned .settings directory from the checked out project and copied in the dierctory from the original project with the IDE closed. Then when I started the IDE again it had changed the board settings to a different version and it all seems to work.
So the takeaway is that this probably needs to be in the version control to make sure that the project as checked out will build the same for all developers.
I also noted that there probably should be a readme file created outlining for instance how to set up the development system library-wise before loading the project.
Menu: "Window/Preferences/Arduino/Platforms and Boards", expand esp8266/esp8266 and check all of the versions available. Then Apply and wait until the IDE has finished. This can take a long time and there is nearly no feedback except for a message that it us busy when one tries to do something else...
So I guess the versioning of projects is now also in a working state.
Thanks again!

New question:
Is there an easy way to copy/clone a project inside the Sloeber IDE to one with a different name?

I have a working project and now I want to use that as a base for another project where I will remove the UART-bridge and instead add some other functions for logging data to a webserver. But I want to keep the base functionality with the Webupdater and also the configuration system for the way the WiFi shall be set up and stored in EEPROM.

So the easiest seems to be to grab a copy of this project and then change it. However, I am not sure how this would be done inside the Sloeber IDE. I think I cannot just copy the entire folder to a different name and then open the project in the IDE...

google "eclipse clone project"

OK, found this on StackOverflow…

So I Copy/Paste in the Project Explorer to create a renamed (for Eclipse) project.

Next I used WinMerge to compare the original and cloned folders and found:

  • The rename did not extend to the main project file (the .ino file) so they are the same. Should the ino file not be named the same as the project folder?
  • During the clone the content of the original Release folder was erased, so the bin file disappeared! Is this normal? If so what should one do in order to keep and version the resulting bin file in a project? After all it is the final result file.
    I am used to having the output file only change when compiling/build a project.
  • Also it copied the subversion .svn folder so any change made here will affect the original Subversion project. Could cause lots of unintended problems if one is not careful.

Additional questions:

  • How I can correctly change the name of the main project ino file so the two sketches are not named the same…
    I right-clicked it and found the “Rename” command, is that the correct way?
  • Is it possible to make Sloeber switch source file view with the project so that when changing active project the source files also change in the edit pane to the right? Or is there a way to highlight tabs belonging to the selected project in order to minimize the risk of editing the files in the wrong project?
  • I want to reduce the tab width in the editor view but have not found a working way. Is it possible?
    I have gone to Window/Preferences/General/Editors/TextEditors/
    Here I have set Displayed tab width = 2 and checked “Insert spaces for tabs”
    But no change in the display, still 4 spaces for each tab.

I would create a new project and copy only the source files (ino, h, cpp) and eventually the .project a .cproject files (with rename in .project).

You can rename ino files without problems. Sloeber doesn't force you to name the ino file like the project. It is required only by Arduino IDE.

Release folder of Sloeber project is a temporary folder. Arduino IDE makes the build in system temp folder.

The project source set view would be a feature of Eclipse. I do not know if it has it. Google "eclipse project view" or similar.

For tab settings, open the Eclipse Preferences and type "tab" in the search field. C++/Editor/Typing is the right section, I think.

This is very strange what happened...
I renamed the ino file to DHT_MONITOR.ino in the Project Explorer view. Seemed OK.
Then I tested a "Verify" build and it succeeded.
But when I look at the IDE I see that the DHT_MONITOR.ino entry has a red x mark on it.
So I looked at the file itself in the editor and found that one line has a red mark on it:

SerialSS.write(buf, bytesIn);

And the message shown when I hover the mouse over the red mark says:

Invalid arguments '
Candidates are:
unsigned int write(unsigned long int)
unsigned int write(long int)
unsigned int write(unsigned int)
unsigned int write(int)
unsigned int write(const char *)
unsigned int write(unsigned char)
'

What can have happened here? Why is this line, which has not changed, marked as erroneous?
And why does the verify succeed anyway? There should be an error message if there is an error, right?

EDIT:
I tried to close Sloeber and then start it again, but this same display re-appeared....

the Eclipse C++ indexer is independent from Arduino build tools. In Project menu there is a submenu for reindexing.

Thanks!
That removed the false negatives (I had another one inside another file)!