Installing Arduino SAM boards on Arduino IDE for Arm64

Hi all, I have been trying to work with an arduino due on a NVIDIA Drive PX2. I have installed arduino IDE Beta version for arm64 boards. I tried connecting an uno and burnt a simple code and it works fine. I tried installing " Arduino SAM Boards (32-bits ARM Cortex-M3) by Arduino" to use my arduino due by going to Tools>Board>Boards Manager.

When I click on install, an error pops up saying

" Tool arm-none-eabi-gcc is not available for your operating system."

Can you help me out to resolve this issue?

They have not compiled the version of arm-none-eabi-gcc and BOSSAC used by the "Arduino SAM Boards" platform for ARM Linux 64 bit. However, the "Arduino SAMD Boards" platform uses the same tools, only newer versions. I created my own version of the Boards Manager package index for the "Arduino SAM Boards" platform that installs the new tools.

The only other modification I made when compared to the official from "Arduino SAM Boards" platform 1.6.11 is that I had to remove the -gcc flag fromrecipe.c.combine.pattern because that flag causes compilation to fail when used with the newer arm-none-eabi-gcc version:

arm-none-eabi-gcc: error: unrecognized debug output level 'cc'

Here's how to install it

  1. Select File > Preferences from the Arduino IDE's menus.
  2. In the "Additional Boards Manager URLs" field, add this URL:
    https://per1234.github.io/ArduinoCore-sam/package_per1234_samarm64_index.json
    
    If you have a URL in that field already, separate them with a comma.
  3. Click the OK button.
  4. Select Tools > Board > Boards Manager from the Arduino IDE's menus.
    1.Wait for the update to finish.
  5. Scroll down through the list of available boards platforms until you see "Arduino SAM Boards (Arduino SAM Boards (32-bits ARM Cortex-M3) with ARM64 support by per1234". Click on it.
  6. Click the Install button.
  7. Wait for the installation to finish.
  8. Click the Close button.

You will now have the Due boards under the Tools > Board menu. Let me know how it works for you.

I don't own the Due or ARM 64 hardware so this is hardly tested at all.

Hey pert,
I followed your instructions and it works fine. Thanks a lot for getting back on this.

I'm very glad to hear it worked. Enjoy!
Per