issue extending ws2811 pixel strips

hi all.

i have a strange issue.
i have 3 x 2 meter ws2811 pixel strip.

12v power goes parallel to all strips and the data is in serie. (pc psu)
i use a wemos d1 (esp8266) with logic level shifter

when the strip was in one piece it was running fine, so the controller works perfect.
i use a capacitor on the beginning of the strip and a 510ohm resistor on the first pixel

for the project i needed 3 x 2 meter (60 pixels) with spacing of about 2 meters.
i connected the data wire and the strip starts to random flash like crazy.

the last pixel of the first strip is flashing a random pattern.
the second strip is acting erratic. the pattern is barely recognizable.
the 3th strip does nothing except a few pixels lighting up

somehow the data can barely make it trough the extension wires.
tried different wires. 18 awg - 22awg - strand solid core utp.
510ohm resistor on each following strip. capacitor on each strip

still the same problem.
been fighting with the issue for days.

somebody any idea what i can try more?

Use a separate data wire for each one?

See my suggestion here to essentially an identical problem.

Also please explain what you mean by a "logic level shifter"?

Yes as Paul__B says you need a 5V signal. If you use a logic level shifter designed for I2C then it might not be false enough. There have been reports of these behaving intermittently when you touch them, always a bad sign.

Also 2 meters is a long way for the signal to go between strips. I would try a none inverting buffer between the strips and I would put a capacitor on the start of every strip. Maybe even go so far as wiring the power separately to each of the strips, that is not using the power that comes through the previous strip.